summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-02-05 09:30:17 +0100
committerMartchus2020-02-05 09:30:17 +0100
commit6c223ad524bdee43b833f7ef945bb8a9e7131287 (patch)
tree5fee5024033338db5e9e6abcc3c9fbd1d4dce31e
parent4ed8981208cc7a106376513902d0b7a5c39dcb93 (diff)
downloadaur-6c223ad524bdee43b833f7ef945bb8a9e7131287.tar.gz
Make libs installable alongside the regular version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d12e1d4cdb8b..5907be414037 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = c++utilities-git
pkgdesc = Common C++ classes and routines such as argument parser, IO and conversion utilities
- pkgver = 259.663b31c
- pkgrel = 1
+ pkgver = 791.eadb261
+ pkgrel = 2
url = https://github.com/Martchus/cpp-utilities
arch = i686
arch = x86_64
@@ -13,7 +13,6 @@ pkgbase = c++utilities-git
makedepends = cmake
makedepends = git
optdepends = c++utilities-doc: API documentation
- conflicts = c++utilities
source = cpp-utilities::git://github.com/Martchus/cpp-utilities.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 64617ff892fc..1bc630b42cec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_reponame=cpp-utilities
pkgname=c++utilities-git
_name=${pkgname%-git}
-pkgver=259.663b31c
-pkgrel=1
+pkgver=791.eadb261
+pkgrel=2
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Common C++ classes and routines such as argument parser, IO and conversion utilities'
license=('GPL')
@@ -16,7 +16,7 @@ optdepends=("$_name-doc: API documentation")
makedepends=('cmake' 'git')
checkdepends=('cppunit')
#provides=("${_name}")
-conflicts=("${_name}")
+#conflicts=("${_name}")
url="https://github.com/Martchus/${_reponame}"
source=("${_reponame}::${MARTCHUS_GIT_URL_PREFIX:-git://github.com/Martchus}/${_reponame}.git")
sha256sums=('SKIP')
@@ -31,6 +31,9 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE:STRING='Release' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DCONFIGURATION_NAME:STRING='git' \
+ -DCONFIGURATION_PACKAGE_SUFFIX:STRING='-git' \
+ -DCONFIGURATION_TARGET_SUFFIX:STRING='git' \
-DBUILD_SHARED_LIBS:BOOL=ON \
.
make