summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-09-09 15:25:22 -0400
committerGuillaume Horel2019-09-09 15:25:22 -0400
commita4f882b09979dbd9e46619fa05881185e5487a17 (patch)
treea00e03bff8cd093c81d9be80b033b3eaf48ae19c
downloadaur-a4f882b09979dbd9e46619fa05881185e5487a17.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE10
-rw-r--r--PKGBUILD38
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa6d0adf8220
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = c-ares-cmake
+ pkgdesc = C library that performs DNS requests and name resolves asynchronously (with cmake build files)
+ pkgver = 1.15.0
+ pkgrel = 1
+ url = https://c-ares.haxx.se/
+ arch = x86_64
+ license = custom
+ depends = glibc
+ provides = c-ares
+ conflicts = c-ares
+ source = https://c-ares.haxx.se/download/c-ares-1.15.0.tar.gz
+ source = LICENSE
+ sha512sums = a1de6c5e7e1a6a13c926aae690e83d5caa51e7313d63da1cf2af6bc757c41d585aad5466bc3ba7b7f7793cb1748fa589f40972b196728851c8b059cfc8c3be50
+ sha512sums = 55e8607392c5f82ed85e3580fa632dfdc2dcd0b1a5e918dc61d00532c15c11ecb709f6007b65805c1fbe8fcd21ee794c9e4a9638c97ac1f4960b2654010a4d0a
+
+pkgname = c-ares-cmake
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e3f5b64fe475
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,10 @@
+Copyright 1998 by the Massachusetts Institute of Technology.
+
+Permission to use, copy, modify, and distribute this software and its
+documentation for any purpose and without fee is hereby granted, provided that
+the above copyright notice appear in all copies and that both that copyright
+notice and this permission notice appear in supporting documentation, and that
+the name of M.I.T. not be used in advertising or publicity pertaining to
+distribution of the software without specific, written prior permission.
+M.I.T. makes no representations about the suitability of this software for any
+purpose. It is provided "as is" without express or implied warranty.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1f2760eac66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Jeff Mickey <jeff@archlinux.org>
+# Contributor: Alexander Fehr <pizzapunk gmail com>
+
+pkgname=c-ares-cmake
+_pkgname=c-ares
+pkgver=1.15.0
+pkgrel=1
+pkgdesc='C library that performs DNS requests and name resolves asynchronously (with cmake build files)'
+arch=('x86_64')
+url='https://c-ares.haxx.se/'
+license=('custom')
+depends=('glibc')
+source=("https://c-ares.haxx.se/download/$_pkgname-$pkgver.tar.gz"
+ 'LICENSE')
+sha512sums=('a1de6c5e7e1a6a13c926aae690e83d5caa51e7313d63da1cf2af6bc757c41d585aad5466bc3ba7b7f7793cb1748fa589f40972b196728851c8b059cfc8c3be50'
+ '55e8607392c5f82ed85e3580fa632dfdc2dcd0b1a5e918dc61d00532c15c11ecb709f6007b65805c1fbe8fcd21ee794c9e4a9638c97ac1f4960b2654010a4d0a')
+provides=('c-ares')
+conflicts=('c-ares')
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ mkdir -p build; cd build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ ..
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver/build"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}