summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Squartini2019-06-30 14:42:33 +0900
committerNicola Squartini2019-06-30 14:42:33 +0900
commit6ca8f52f6f5c21046b2fcd86eb5bc77b03d01da7 (patch)
tree248e6dcb2a40f0d25e359207d37f06b9c7c6318c
parent16f3bb9e72bf8551267f528a4fd20c2b800222de (diff)
downloadaur-6ca8f52f6f5c21046b2fcd86eb5bc77b03d01da7.tar.gz
Update to fa1c8b36
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD43
-rw-r--r--macro-quotation.patch11
3 files changed, 37 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6be7c14fb449..0f241856133e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,29 @@
pkgbase = c-lightning-git
pkgdesc = A Lightning Network implementation in C
- pkgver = r2936.b3534462
+ pkgver = r5960.fa1c8b36
pkgrel = 1
url = https://github.com/ElementsProject/lightning
arch = i686
arch = x86_64
license = custom
+ makedepends = clang
makedepends = git
+ makedepends = python-pytest
+ depends = gmp
+ depends = libsodium
depends = sqlite
source = git+https://github.com/ElementsProject/lightning.git
source = git+https://github.com/zserge/jsmn.git
source = git+https://github.com/ianlancetaylor/libbacktrace.git
- source = git+https://github.com/bitcoin/libbase58.git
source = git+https://github.com/jedisct1/libsodium.git
- source = libbacktrace-no-multilib.patch
+ source = git+https://github.com/ElementsProject/libwally-core.git
+ source = macro-quotation.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 5f843b31b1be859994413a826d8814c6d3ea29d99d8ea59d2372d8a1f3ba036f
+ sha256sums = 35e294ffdc49c02f8e9d79b7122dab4c4d4ebd8321c1b98ba518127bb6e0d423
pkgname = c-lightning-git
diff --git a/PKGBUILD b/PKGBUILD
index 353d568bfc70..7f3d1ba783ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Nicola Squartini <tensor5@gmail.com>
pkgname=c-lightning-git
-pkgver=r2936.b3534462
+pkgver=r5960.fa1c8b36
pkgrel=1
pkgdesc='A Lightning Network implementation in C'
arch=('i686' 'x86_64')
url='https://github.com/ElementsProject/lightning'
license=('custom')
-depends=('sqlite')
-makedepends=('git')
+depends=('gmp' 'libsodium' 'sqlite')
+makedepends=('clang' 'git' 'python-pytest')
source=('git+https://github.com/ElementsProject/lightning.git'
'git+https://github.com/zserge/jsmn.git'
'git+https://github.com/ianlancetaylor/libbacktrace.git'
- 'git+https://github.com/bitcoin/libbase58.git'
'git+https://github.com/jedisct1/libsodium.git'
- 'libbacktrace-no-multilib.patch')
+ 'git+https://github.com/ElementsProject/libwally-core.git'
+ 'macro-quotation.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- '5f843b31b1be859994413a826d8814c6d3ea29d99d8ea59d2372d8a1f3ba036f')
+ '35e294ffdc49c02f8e9d79b7122dab4c4d4ebd8321c1b98ba518127bb6e0d423')
pkgver() {
cd lightning
@@ -37,38 +37,31 @@ prepare() {
git submodule init external/libbacktrace
git config submodule.external/libbacktrace.url "${srcdir}/libbacktrace"
- git submodule init external/libbase58
- git config submodule.bitcoin/libbase58.url "${srcdir}/libbase58"
-
git submodule init external/libsodium
git config submodule.libsodium.url "${srcdir}/libsodium"
+ git submodule init external/libwally-core
+ git config submodule.external/libwally-core.url "${srcdir}/libwally-core"
+
git submodule update
- sed -e 's/ -Werror//' -i Makefile
- cd external/libbacktrace
- patch -p1 -i "${srcdir}/libbacktrace-no-multilib.patch"
+
+ patch -Np1 -i ../macro-quotation.patch
+ sed -e 's/ -Werror//' -i configure
+ sed -e '/include lightningd\/test\/Makefile/d' -i lightningd/Makefile
}
build() {
cd lightning
- cd external/libbacktrace
- #rm aclocal.m4 *.in configure ltmain.sh
- #aclocal && libtoolize --force && autoreconf
- autoreconf --force --install
- #libtoolize --force
- cd ../..
-
- make
+ env CC=clang \
+ COPTFLAGS="${CFLAGS}" \
+ PYTEST=pytest ./configure --prefix=/usr
+ make LDFLAGS="${LDFLAGS}" libexecdir=/usr/lib
}
package() {
cd lightning
- install -Dm755 -t "${pkgdir}/usr/bin" \
- cli/lightning-cli \
- lightningd/lightningd
+ make DESTDIR="${pkgdir}" libexecdir=/usr/lib install
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
- install -Dm644 -t "${pkgdir}/usr/share/man/man1" doc/*.1
- install -Dm644 -t "${pkgdir}/usr/share/man/man7" doc/*.7
}
diff --git a/macro-quotation.patch b/macro-quotation.patch
new file mode 100644
index 000000000000..c5e1b6afc3f4
--- /dev/null
+++ b/macro-quotation.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -188,7 +188,7 @@
+
+ ALL_PROGRAMS =
+
+-CPPFLAGS = -DBINTOPKGLIBEXECDIR='"'$(shell sh tools/rel.sh $(bindir) $(pkglibexecdir))'"'
++CPPFLAGS = -DBINTOPKGLIBEXECDIR="\"$(shell sh tools/rel.sh $(bindir) $(pkglibexecdir))\""
+ CFLAGS = $(CPPFLAGS) $(CWARNFLAGS) $(CDEBUGFLAGS) $(COPTFLAGS) -I $(CCANDIR) $(EXTERNAL_INCLUDE_FLAGS) -I . -I/usr/local/include $(FEATURES) $(COVFLAGS) $(DEV_CFLAGS) -DSHACHAIN_BITS=48 -DJSMN_PARENT_LINKS $(PIE_CFLAGS) $(COMPAT_CFLAGS)
+
+ # We can get configurator to run a different compile cmd to cross-configure.