summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Band2016-09-05 20:57:42 +0200
committerRicardo Band2016-09-05 20:57:42 +0200
commit32bad446b4973c5b0d44d6eee8331796608ad7c2 (patch)
tree6f2ae0b152aa9018c2ca37c12b2a4c25c38a9534
downloadaur-32bad446b4973c5b0d44d6eee8331796608ad7c2.tar.gz
initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..724542ac1497
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Sep 5 18:57:14 UTC 2016
+pkgbase = c-lolcat
+ pkgdesc = High-performance implementation of lolcat
+ pkgver = r25.88c27c9
+ pkgrel = 1
+ url = https://github.com/jaseg/lolcat
+ arch = i686
+ arch = x86_64
+ license = WTFPL
+ conflicts = lolcat
+ conflicts = python-lolcat
+ source = c-lolcat::git+https://github.com/jaseg/lolcat.git
+ sha256sums = SKIP
+
+pkgname = c-lolcat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7778f98a7ce8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ricardo (XenGi) Band <email@ricardo.band>
+
+pkgname=c-lolcat
+pkgver=r25.88c27c9
+pkgrel=1
+pkgdesc="High-performance implementation of lolcat"
+arch=('i686' 'x86_64')
+url="https://github.com/jaseg/lolcat"
+license=('WTFPL')
+depends=()
+makedepends=()
+conflicts=('lolcat' 'python-lolcat')
+source=("$pkgname"::'git+https://github.com/jaseg/lolcat.git')
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "${pkgdir}/usr/local/bin"
+ make install # DESTDIR="$pkgdir/" install
+}