summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Band2016-10-27 11:00:08 +0200
committerRicardo Band2016-10-27 11:00:08 +0200
commitb215d5749dbf1b1109767bc2c255576a3ee95410 (patch)
tree801264272757320ff6e8499051f02d3f6e5878ef
parent32bad446b4973c5b0d44d6eee8331796608ad7c2 (diff)
downloadaur-b215d5749dbf1b1109767bc2c255576a3ee95410.tar.gz
fixed
-rw-r--r--.gitignore83
-rw-r--r--PKGBUILD10
2 files changed, 88 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..132b25642e74
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,83 @@
+
+# Created by https://www.gitignore.io/api/c,archlinuxpackages,vim
+
+### C ###
+# Prerequisites
+*.d
+
+# Object files
+*.o
+*.ko
+*.obj
+*.elf
+
+# Linker output
+*.ilk
+*.map
+*.exp
+
+# Precompiled Headers
+*.gch
+*.pch
+
+# Libraries
+*.lib
+*.a
+*.la
+*.lo
+
+# Shared objects (inc. Windows DLLs)
+*.dll
+*.so
+*.so.*
+*.dylib
+
+# Executables
+*.exe
+*.out
+*.app
+*.i*86
+*.x86_64
+*.hex
+
+# Debug files
+*.dSYM/
+*.su
+*.idb
+*.pdb
+
+# Kernel Module Compile Results
+*.mod*
+*.cmd
+modules.order
+Module.symvers
+Mkfile.old
+dkms.conf
+
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+
+### Vim ###
+# swap
+[._]*.s[a-w][a-z]
+[._]s[a-w][a-z]
+# session
+Session.vim
+# temporary
+.netrwhist
+*~
+# auto-generated tag files
+tags
diff --git a/PKGBUILD b/PKGBUILD
index 7778f98a7ce8..8b84cb327c95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Ricardo (XenGi) Band <email@ricardo.band>
pkgname=c-lolcat
-pkgver=r25.88c27c9
-pkgrel=1
+pkgver=r27.33ee440
+pkgrel=2
pkgdesc="High-performance implementation of lolcat"
arch=('i686' 'x86_64')
url="https://github.com/jaseg/lolcat"
license=('WTFPL')
depends=()
makedepends=()
-conflicts=('lolcat' 'python-lolcat')
+conflicts=('lolcat')
source=("$pkgname"::'git+https://github.com/jaseg/lolcat.git')
sha256sums=(SKIP)
@@ -25,6 +25,6 @@ build() {
package() {
cd "$srcdir/$pkgname"
- mkdir -p "${pkgdir}/usr/local/bin"
- make install # DESTDIR="$pkgdir/" install
+ mkdir -p "${pkgdir}/usr/bin"
+ make DESTDIR="$pkgdir/usr/bin" install
}