summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsiphr2022-03-13 21:09:34 +0000
committersiphr2022-03-13 21:09:34 +0000
commitfdae89f47ec307e4f95383809c78294db5321305 (patch)
treeea668bd05f0e7572a69b528369e6085483565e7d
parent4151ae7d70e37c9a76a7f082fad06829f6480b3f (diff)
downloadaur-fdae89f47ec307e4f95383809c78294db5321305.tar.gz
bump
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
2 files changed, 25 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caf224612fee..f3715c848422 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = c19
pkgdesc = COVID-19 Stats for the country of Pakistan.
- pkgver = 0.0
- pkgrel = 3
+ pkgver = 0.0.7
+ pkgrel = 1
url = https://www.techtum.dev/work-c19-220109.html
- arch = x86_64
+ arch = any
license = MIT
depends = python
- source = https://github.com/siphr/c19.git
- md5sums = SKIP
+ depends = python-pycountry
+ source = https://github.com/siphr/c19/archive/refs/tags/0.0.7.tar.gz
+ md5sums = 72e3b38c73b0cd380eb9f7685fa7d7e7
pkgname = c19
diff --git a/PKGBUILD b/PKGBUILD
index 6f43eb3293bf..0bd148a367c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,34 @@
# Maintainer: siphr <archlinux@techtum.dev>
+
pkgname=c19
-pkgver=0.0
-pkgrel=3
+pkgver=0.0.7
+pkgrel=1
pkgdesc="COVID-19 Stats for the country of Pakistan."
-depends=(python)
-arch=(x86_64)
-source=("https://github.com/siphr/c19.git")
+depends=(python python-pycountry)
+arch=(any)
+source=("https://github.com/siphr/c19/archive/refs/tags/$pkgver.tar.gz")
url=https://www.techtum.dev/work-c19-220109.html
license=('MIT')
build() {
- echo "PREPARING..."
- pip install pycountry
- pip install c19
-
- echo "echo BUILD DATE: `date`" > c19
- echo "python -m c19 \$@" >> c19
+ echo "BUILDING..."
+ cd "$srcdir/$pkgname-$pkgver/pip/"
+ python setup.py build
- chmod +x $srcdir/c19
+ echo -e '#!/bin/sh\n\nexec python -m c19.c19 "$@"' > _c19
+ #echo "python -m c19 \$@" >> c19
}
package() {
echo "INSTALLING..."
+ cd "$srcdir/$pkgname-$pkgver/pip"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
mkdir -p $pkgdir/usr/bin
- cp "$srcdir/c19" "$pkgdir/usr/bin/c19"
+ cp _c19 "$pkgdir/usr/bin/c19"
+ chmod +x "$pkgdir/usr/bin/c19"
+
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
echo 'Finished setting up c19.'
}
-md5sums=('SKIP')
+md5sums=('72e3b38c73b0cd380eb9f7685fa7d7e7')