summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-16 05:38:48 +0200
committerDimitris Kiziridis2020-03-16 05:38:48 +0200
commitd43a4152a044c195f402af8d601a0cd1c7bb434c (patch)
tree507dde1d71921404c0b295b1809c284f15e791e4
downloadaur-d43a4152a044c195f402af8d601a0cd1c7bb434c.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ef9ce9d9e57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = c2go
+ pkgdesc = A tool for transpiling C to Go
+ pkgver = 0.25.9
+ pkgrel = 1
+ url = https://github.com/elliotchance/c2go
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ source = c2go-0.25.9.tar.gz::https://github.com/elliotchance/c2go/archive/v0.25.9.tar.gz
+ md5sums = c1ac9bf2637725238711070b2a7228d1
+
+pkgname = c2go
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61e88bca826e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=c2go
+pkgver=0.25.9
+pkgrel=1
+pkgdesc="A tool for transpiling C to Go"
+arch=('x86_64')
+url='https://github.com/elliotchance/c2go'
+license=('MIT')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+md5sums=('c1ac9bf2637725238711070b2a7228d1')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p $srcdir/go
+ export GOPATH="${srcdir}"/go
+ export PATH=$PATH:$GOPATH/bin
+ go get -d -v ./...
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ go build -v -o "../c2go-bin"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 ../c2go-bin "${pkgdir}/usr/bin/c2go"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/c2go/LICENSE"
+ go clean -modcache #Remove go libraries
+} \ No newline at end of file