summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornimaaskarian2024-01-23 14:55:04 +0330
committernimaaskarian2024-01-23 14:55:04 +0330
commitd3b00426808d3c4e7f542a97499a3da66640a1d8 (patch)
treef529cf9cebfdc4f2e5d41736b6120c6aba3bf91e
downloadaur-d3b00426808d3c4e7f542a97499a3da66640a1d8.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..563addfa0a72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = c3-bin
+ pkgdesc = A TUI to-do list that uses and extends calcurse format to have tree-like dependencies.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/nimaaskarian/c3
+ arch = x86_64
+ license = GPL3
+ makedepends = ncurses
+ makedepends = cargo
+ optdepends = potato-c: pomodoro timer module
+ provides = c3
+ source = c3-bin::https://github.com/nimaaskarian/c3/releases/download/0.3.0/c3.x86.linux
+ md5sums = 8a7b25753c3608efe1511834ee325c77
+
+pkgname = c3-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e13bd6450db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Nima Askarian <nimaas1400@gmail.com>
+pkgname=c3-bin
+pkgver=0.3.0
+pkgrel=1
+_gitname=c3
+pkgdesc="A TUI to-do list that uses and extends calcurse format to have tree-like dependencies."
+url="https://github.com/nimaaskarian/${_gitname}"
+
+provides=(c3)
+makedepends=(ncurses cargo)
+arch=('x86_64')
+license=('GPL3')
+optdepends=('potato-c: pomodoro timer module')
+
+source=(
+ "${pkgname}::https://github.com/nimaaskarian/${_gitname}/releases/download/${pkgver}/c3.x86.linux"
+)
+
+md5sums=('8a7b25753c3608efe1511834ee325c77')
+
+package () {
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/c3"
+}