summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo José Gómez Hernández2023-11-22 09:19:42 +0100
committerEduardo José Gómez Hernández2023-11-22 09:19:42 +0100
commita27aa1a79940c558dc4ac7c2e2778451cdd38320 (patch)
tree86d11d73f54b9a6c06d522613586a3ff3da1aa6e
downloadaur-a27aa1a79940c558dc4ac7c2e2778451cdd38320.tar.gz
Stable Release (pre-built)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..565a209862b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = c3c-bin
+ pkgdesc = C3 is an evolution of C enabling the same paradigms and retaining the same syntax as far as possible. Stable Release (with LLVM 16)
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/c3lang/c3c.git
+ arch = x86_64
+ license = LGPL3
+ license = MIT
+ makedepends = binutils
+ provides = c3c
+ conflicts = c3c
+ source = https://github.com/c3lang/c3c/releases/download/release_0.5/c3-linux.tar-6.gz
+ md5sums = e97e051ba4115265dcd47ba486665aae
+
+pkgname = c3c-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..993715f9d707
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Eduardo Jose Gomez Hernandez <eduardo@edujgh.net>
+pkgname=c3c-bin
+_pkgname=c3c
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="C3 is an evolution of C enabling the same paradigms and retaining the same syntax as far as possible. Stable Release (with LLVM 16)"
+arch=(x86_64)
+url="https://github.com/c3lang/c3c.git"
+license=('LGPL3' 'MIT')
+depends=()
+makedepends=('binutils')
+provides=(c3c)
+conflicts=(c3c)
+
+source=('https://github.com/c3lang/c3c/releases/download/release_0.5/c3-linux.tar-6.gz')
+md5sums=('e97e051ba4115265dcd47ba486665aae')
+
+package() {
+ echo "Hola"
+ cd "${srcdir}/linux/"
+
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/lib/${_pkgname}"
+
+ cp "${srcdir}/linux/c3c" "${pkgdir}/usr/lib/${_pkgname}/c3c"
+ cp -r "${srcdir}/linux/lib" "${pkgdir}/usr/lib/${_pkgname}/lib"
+ ln -s "/usr/lib/${_pkgname}/c3c" "${pkgdir}/usr/bin/c3c"
+}
+