summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Pantano2020-04-15 10:06:52 +0200
committerFrancesco Pantano2020-04-15 10:06:52 +0200
commit0683d080785789412a6250f9238ba9ddd6bc6c3b (patch)
tree6aeeed889596da28bc8e5a00cf5d2160de31dfa8
parent42166f5cc82b32101851ebc4f83dde119725bcc4 (diff)
downloadaur-0683d080785789412a6250f9238ba9ddd6bc6c3b.tar.gz
Serious memory leaks fix and code base improvment
This is a rework of the main parsing providerrc function which is afftected by serious memory leaks. The code base is revisited providing a few improvements and optimizations in the way the memory structures are allocated, used and freed. Signed-off-by: Francesco Pantano <fpantano@redhat.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 389d84822936..e6c0d7db6c4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = c_otp
pkgdesc = HOTP / TOTP pure C implementation
- pkgver = v1.0
- pkgrel = 1
+ pkgver = v1.1
+ pkgrel = 2
url = htps://github.com/fmount/c_otp.git
arch = i686
arch = x86_64
license = MIT
depends = openssl
- source = git://github.com/fmount/c_otp.git
+ source = git+https://github.com/fmount/c_otp.git#tag=v1.1
md5sums = SKIP
pkgname = c_otp
diff --git a/PKGBUILD b/PKGBUILD
index 0bf577ed8c0c..8448bc11a482 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
pkgname=('c_otp')
_pkgname="c_otp"
packager="fmount"
-pkgver=v1.0
-pkgrel=1
+pkgver=v1.1
+pkgrel=2
bindir=usr/bin
pkgdesc="HOTP / TOTP pure C implementation"
url="htps://github.com/fmount/${pkgname}.git"
arch=('i686' 'x86_64')
license=('MIT')
depends=('openssl')
-source=("git://github.com/fmount/${pkgname}.git")
+source=("git+https://github.com/fmount/${pkgname}.git#tag=${pkgver}")
md5sums=('SKIP')
pkgver() {