summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfmount2018-07-30 14:26:27 +0200
committerfmount2018-07-30 14:26:27 +0200
commit42166f5cc82b32101851ebc4f83dde119725bcc4 (patch)
tree38ab703d3df74d7c180400529ef641da2e7d25ca
downloadaur-42166f5cc82b32101851ebc4f83dde119725bcc4.tar.gz
Importing PKGBUILD and related METADATA
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..389d84822936
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = c_otp
+ pkgdesc = HOTP / TOTP pure C implementation
+ pkgver = v1.0
+ pkgrel = 1
+ url = htps://github.com/fmount/c_otp.git
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = openssl
+ source = git://github.com/fmount/c_otp.git
+ md5sums = SKIP
+
+pkgname = c_otp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bf577ed8c0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Francesco Pantano <fmount9@autistici.org>
+# Contributor: fmount
+
+pkgname=('c_otp')
+_pkgname="c_otp"
+packager="fmount"
+pkgver=v1.0
+pkgrel=1
+bindir=usr/bin
+pkgdesc="HOTP / TOTP pure C implementation"
+url="htps://github.com/fmount/${pkgname}.git"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('openssl')
+source=("git://github.com/fmount/${pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname || exit -1
+ git describe --tags | sed 's/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname" || exit -1
+}
+
+build() {
+ echo "Start building $_pkgname"
+ cd "${srcdir}/$_pkgname" || exit -1
+ echo -e "c_otp: $pkgver" > PKG-INFO
+ make
+}
+
+package() {
+ cd "${srcdir}"/$_pkgname/$bindir || exit -1
+ echo "Copy ${srcdir}/$_pkgname/$bindir/$_pkgname $bindir"
+ #make PREFIX="$pkgdir"/usr DESTDIR="$pkgdir" install
+ install -Dm755 ${srcdir}/$_pkgname/$bindir/$_pkgname "$pkgdir/$bindir/$_pkgname"
+ install -m644 -D ${srcdir}/$_pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}