summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlain Zscheile2021-06-15 16:44:05 +0200
committerStephan Springer2021-06-17 18:07:55 +0200
commit41bcc4974886b53d1a938a0c82758ff3deff0b70 (patch)
tree0f16bb2fc5c0d006b692fce2fae86dd210fe90fd
parentc0810f2e1d90579529c6874f5e4217d8ed05f193 (diff)
downloadaur-41bcc4974886b53d1a938a0c82758ff3deff0b70.tar.gz
add a flake.nix file to ease integration with NixOS
suggested here: https://github.com/NixOS/nixpkgs/issues/117530#issuecomment-860937335 this is easier than providing a package in nixpkgs and keeping that up-to-date and avoids duplicate book-keeping of certificate revisons.
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 000000000000..9b9ea24d1271
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,12 @@
+{
+ description = "dn42 root certificates for *.dn42 and 172.22.0.0/15";
+ outputs = { self }: {
+ nixosModule = { config, lib, ... }: {
+ options.security.pki.dn42.enable =
+ lib.mkEnableOption "dn42 root certificates";
+
+ security.pki.certificateFiles =
+ lib.mkIf config.options.security.pki.dn42.enable [ ./dn42.crt ];
+ };
+ };
+}