aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTiago Brait2016-02-16 13:57:50 -0200
committerTiago Brait2016-02-16 13:57:50 -0200
commitcfd8418acccec08f04a03931faef5ae2b99b3b82 (patch)
treeda117029b2e560babbf27fee5e211fb32937c481
parentc8e65f98ad3303655f610607eb4cb922ff09d8fd (diff)
downloadaur-cfd8418acccec08f04a03931faef5ae2b99b3b82.tar.gz
Update version
Version updated. Apparently I forgot to push my changes the other time I updated this. Really stupid mistake.
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 326a1841a673..946beba8b21f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
#2014 tiagobrait
pkgname=ca-certificates-icp_br
-pkgver=20160110
+pkgver=20160216
pkgrel=1
pkgdesc="Brazilian government Certification Authorities"
arch=('any')
url="http://www.iti.gov.br/icp-brasil/certificados/188-atualizacao/4530-ac-raiz"
license=('GPL')
-depends=('ca-certificates')
+depends=('ca-certificates-utils')
makedepends=('unzip openssl')
install='ca-certificates-icp_br.install'
source=(
@@ -16,22 +16,22 @@ source=(
)
sha512sums=(
- 'e23ee7d5d79f66037afb13f00aae42ffbe86c290fb58331bab97b04ef29f80ff20075876ed85a57b8e3279ebcdcb5d8cb85aa9d380dec343b06cdfea79662998'
+ '1f3bdf14719e9afd26ee156d7f374a4eb8bb2a6c7e53edd0e546e062d602c8acace82454aa056ac63e7b6906f22ec385866ef521431ae470f1d38a8c0577cc54'
)
package() {
local cert_tag='icp_br'
cd ${srcdir}
- find * -print0 | while read -d $'\0' cert; do
- #some certificates have a .crt extension but come in DER format.
- #convert them
- if [[ "$(file $cert | cut -f2 -d\: | tr -d ' ')" = "data" ]]; then
+ find * -print0 | while read -d $'\0' cert; do
+ #some certificates have a .crt extension but come in DER format.
+ #convert them
+ if [[ "$(file $cert | cut -f2 -d\: | tr -d ' ')" = "data" ]]; then
msg2 "converting $cert from DER to PEM..."
- cert_der="${cert}.der"
+ cert_der="${cert}.der"
mv $cert $cert_der
/usr/bin/openssl x509 -in ${cert_der} -inform der -out $cert
rm "$cert_der"
- fi
+ fi
#some of the cert files have spaces in their names, so just remove the spaces
#when 'tagging' the certificates
mv "$cert" "${cert_tag}.${cert//' '/'_'}"; done