summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2013-09-29 13:42:39 +0100
committerLeonidas Spyropoulos2013-09-29 13:42:39 +0100
commit2fc99cfc145acbfaf1bfb497e60cbcf0353640bd (patch)
tree41ac6240cb0d7f2ebac85f7d433b1ee006e9003d
downloadaur-2fc99cfc145acbfaf1bfb497e60cbcf0353640bd.tar.gz
add caatinga-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0448c5fce0c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = caatinga-git
+ pkgdesc = A command line backup program written in Python - Git Version
+ pkgver = 44.c3a06ad
+ pkgrel = 1
+ url = https://github.com/headmastersquall/caatinga
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python2-distribute
+ provides = caatinga
+ conflicts = caatinga
+
+pkgname = caatinga-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d79a4c2c789
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Leonidas Spyropoulos <artafinde at gmail dot com>
+
+pkgname=caatinga-git
+pkgver=44.c3a06ad
+pkgrel=1
+pkgdesc="A command line backup program written in Python - Git Version"
+arch=('any')
+url="https://github.com/headmastersquall/caatinga"
+license=('GPL3')
+depends=('python2-distribute')
+makedepends=('git')
+conflicts=('caatinga')
+provides=('caatinga')
+source=()
+md5sums=()
+
+_gitroot="https://github.com/headmastersquall/caatinga"
+_gitname="caatinga"
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd ${srcdir}
+ msg "Connecting to GIT server.."
+
+ if [ -d ${_gitname} ] ; then
+ cd ${_gitname} && git pull origin
+ msg "The local files are updated."
+ else
+ git clone ${_gitroot} ${_gitname}
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make.."
+
+ cd ${srcdir}/${_gitname}
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: