summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2022-03-22 02:23:15 +0200
committergesh2023-04-21 18:38:41 +0300
commit70421b02c304a7f23c895b6af84572d981745471 (patch)
tree2fd6f55834cabd1f96bd6cc990cffa6682e6f6fc
parent248d9bed96191612e93c75052c13be39e0c5113f (diff)
downloadaur-70421b02c304a7f23c895b6af84572d981745471.tar.gz
Stop patching compatibility manually
Brittle, and upstream has merged anyway
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Build-with-GHC-8.10.4-and-9.0.1.patch134
-rw-r--r--PKGBUILD15
3 files changed, 4 insertions, 149 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b38807839c5a..7c37fe761db9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cabal-fmt-static-git
pkgdesc = Format .cabal files
- pkgver = 0.1.6.r2.g166bcb4
+ pkgver = 0.1.6.r5.g38dfdf0
pkgrel = 1
url = https://github.com/phadej/cabal-fmt
arch = i686
@@ -10,8 +10,6 @@ pkgbase = cabal-fmt-static-git
depends = gmp
provides = cabal-fmt
source = cabal-fmt-static-git::git+https://github.com/phadej/cabal-fmt.git
- source = 0001-Build-with-GHC-8.10.4-and-9.0.1.patch
sha256sums = SKIP
- sha256sums = 32deb5f7a9278a989980fb19740504c362cdc8787717ee506ec2c3bb3f13690b
pkgname = cabal-fmt-static-git
diff --git a/0001-Build-with-GHC-8.10.4-and-9.0.1.patch b/0001-Build-with-GHC-8.10.4-and-9.0.1.patch
deleted file mode 100644
index 9d3fad8162d5..000000000000
--- a/0001-Build-with-GHC-8.10.4-and-9.0.1.patch
+++ /dev/null
@@ -1,134 +0,0 @@
-From 69a3b5e5af4354eb898370265d41eb6ac316d133 Mon Sep 17 00:00:00 2001
-From: Peter Jones <pjones@devalot.com>
-Date: Wed, 2 Jun 2021 15:38:54 -0700
-Subject: [PATCH] Build with GHC 8.10.4 and 9.0.1
-
-No code changes were necessary, just updated bounds.
----
- .github/workflows/haskell-ci.yml | 40 ++++++++++++++++++--------------
- cabal-fmt.cabal | 4 ++--
- 2 files changed, 24 insertions(+), 20 deletions(-)
-
-diff --git a/.github/workflows/haskell-ci.yml b/.github/workflows/haskell-ci.yml
-index dab2b95..f7db89b 100644
---- a/.github/workflows/haskell-ci.yml
-+++ b/.github/workflows/haskell-ci.yml
-@@ -8,9 +8,9 @@
- #
- # For more information, see https://github.com/haskell-CI/haskell-ci
- #
--# version: 0.11.20210214
-+# version: 0.12.1
- #
--# REGENDATA ("0.11.20210214",["github","cabal.project"])
-+# REGENDATA ("0.12.1",["github","cabal.project"])
- #
- name: Haskell-CI
- on:
-@@ -22,21 +22,23 @@ on:
- - master
- jobs:
- linux:
-- name: Haskell-CI - Linux - GHC ${{ matrix.ghc }}
-+ name: Haskell-CI - Linux - ${{ matrix.compiler }}
- runs-on: ubuntu-18.04
- container:
-- image: buildpack-deps:bionic
-+ image: buildpack-deps:xenial
- continue-on-error: ${{ matrix.allow-failure }}
- strategy:
- matrix:
- include:
-- - ghc: 8.10.2
-+ - compiler: ghc-9.0.1
- allow-failure: false
-- - ghc: 8.8.4
-+ - compiler: ghc-8.10.4
- allow-failure: false
-- - ghc: 8.6.5
-+ - compiler: ghc-8.8.4
- allow-failure: false
-- - ghc: 8.4.4
-+ - compiler: ghc-8.6.5
-+ allow-failure: false
-+ - compiler: ghc-8.4.4
- allow-failure: false
- fail-fast: false
- steps:
-@@ -46,29 +48,31 @@ jobs:
- apt-get install -y --no-install-recommends gnupg ca-certificates dirmngr curl git software-properties-common
- apt-add-repository -y 'ppa:hvr/ghc'
- apt-get update
-- apt-get install -y ghc-$GHC_VERSION cabal-install-3.2
-+ apt-get install -y $CC cabal-install-3.4
- env:
-- GHC_VERSION: ${{ matrix.ghc }}
-+ CC: ${{ matrix.compiler }}
- - name: Set PATH and environment variables
- run: |
- echo "$HOME/.cabal/bin" >> $GITHUB_PATH
- echo "LANG=C.UTF-8" >> $GITHUB_ENV
- echo "CABAL_DIR=$HOME/.cabal" >> $GITHUB_ENV
- echo "CABAL_CONFIG=$HOME/.cabal/config" >> $GITHUB_ENV
-- HC=/opt/ghc/$GHC_VERSION/bin/ghc
-+ HCDIR=$(echo "/opt/$CC" | sed 's/-/\//')
-+ HCNAME=ghc
-+ HC=$HCDIR/bin/$HCNAME
- echo "HC=$HC" >> $GITHUB_ENV
-- echo "HCPKG=/opt/ghc/$GHC_VERSION/bin/ghc-pkg" >> $GITHUB_ENV
-- echo "HADDOCK=/opt/ghc/$GHC_VERSION/bin/haddock" >> $GITHUB_ENV
-- echo "CABAL=/opt/cabal/3.2/bin/cabal -vnormal+nowrap" >> $GITHUB_ENV
-+ echo "HCPKG=$HCDIR/bin/$HCNAME-pkg" >> $GITHUB_ENV
-+ echo "HADDOCK=$HCDIR/bin/haddock" >> $GITHUB_ENV
-+ echo "CABAL=/opt/cabal/3.4/bin/cabal -vnormal+nowrap" >> $GITHUB_ENV
- HCNUMVER=$(${HC} --numeric-version|perl -ne '/^(\d+)\.(\d+)\.(\d+)(\.(\d+))?$/; print(10000 * $1 + 100 * $2 + ($3 == 0 ? $5 != 1 : $3))')
- echo "HCNUMVER=$HCNUMVER" >> $GITHUB_ENV
- echo "ARG_TESTS=--enable-tests" >> $GITHUB_ENV
- echo "ARG_BENCH=--enable-benchmarks" >> $GITHUB_ENV
- echo "HEADHACKAGE=false" >> $GITHUB_ENV
-- echo "ARG_COMPILER=--ghc --with-compiler=/opt/ghc/$GHC_VERSION/bin/ghc" >> $GITHUB_ENV
-+ echo "ARG_COMPILER=--$HCNAME --with-compiler=$HC" >> $GITHUB_ENV
- echo "GHCJSARITH=0" >> $GITHUB_ENV
- env:
-- GHC_VERSION: ${{ matrix.ghc }}
-+ CC: ${{ matrix.compiler }}
- - name: env
- run: |
- env
-@@ -147,9 +151,9 @@ jobs:
- - name: cache
- uses: actions/cache@v2
- with:
-- key: ${{ runner.os }}-${{ matrix.ghc }}-${{ github.sha }}
-+ key: ${{ runner.os }}-${{ matrix.compiler }}-${{ github.sha }}
- path: ~/.cabal/store
-- restore-keys: ${{ runner.os }}-${{ matrix.ghc }}-
-+ restore-keys: ${{ runner.os }}-${{ matrix.compiler }}-
- - name: install dependencies
- run: |
- $CABAL v2-build $ARG_COMPILER --disable-tests --disable-benchmarks --dependencies-only -j2 all
-diff --git a/cabal-fmt.cabal b/cabal-fmt.cabal
-index 7f74e89..9031b7e 100644
---- a/cabal-fmt.cabal
-+++ b/cabal-fmt.cabal
-@@ -12,7 +12,7 @@ license: GPL-3.0-or-later AND BSD-3-Clause
- license-file: LICENSE
- author: Oleg Grenrus <oleg.grenrus@iki.fi>
- maintainer: Oleg Grenrus <oleg.grenrus@iki.fi>
--tested-with: GHC ==8.4.4 || ==8.6.5 || ==8.8.4 || ==8.10.2
-+tested-with: GHC ==8.4.4 || ==8.6.5 || ==8.8.4 || ==8.10.4 || ==9.0.1
- extra-source-files:
- Changelog.md
- fixtures/*.cabal
-@@ -28,7 +28,7 @@ library cabal-fmt-internal
-
- -- GHC boot libraries
- build-depends:
-- , base ^>=4.11.1.0 || ^>=4.12.0.0 || ^>=4.13.0.0 || ^>=4.14.0.0
-+ , base ^>=4.11.1.0 || ^>=4.12.0.0 || ^>=4.13.0.0 || ^>=4.14.0.0 || ^>=4.15.0.0
- , bytestring ^>=0.10.8.2
- , Cabal ^>=3.6.0.0
- , containers ^>=0.5.11.0 || ^>=0.6.0.1
---
-2.33.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 416d7c724dd2..868c8aad97a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cabal-fmt-static-git
_pkgname="${pkgname%-static-git}"
-pkgver=0.1.6.r1.g6651ffd
+pkgver=0.1.6.r5.g38dfdf0
pkgrel=1
pkgdesc="Format .cabal files"
arch=('i686' 'x86_64')
@@ -11,10 +11,8 @@ license=('custom')
provides=("$_pkgname")
depends=('gmp')
makedepends=('cabal-install')
-source=("${pkgname}::git+${url}.git"
- 0001-Build-with-GHC-8.10.4-and-9.0.1.patch)
-sha256sums=('SKIP'
- '32deb5f7a9278a989980fb19740504c362cdc8787717ee506ec2c3bb3f13690b')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
# based on fanficfare-git -- upstream doesn't consistently tag versions, so we
# have to create them for them
@@ -27,13 +25,6 @@ pkgver() {
| sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$pkgname"
- git am ../0001-Build-with-GHC-8.10.4-and-9.0.1.patch
- # patch --forward --strip=1 \
- # --input="${srcdir}/0001-Build-with-GHC-8.10.4-and-9.0.1.patch"
-}
-
build() {
cd "$pkgname"
cabal v2-configure \