summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Flament2016-11-15 01:08:09 +0100
committerDamien Flament2016-11-15 01:08:09 +0100
commit3fc0459ea941c03b153c3115cb40f4433bd3bb51 (patch)
tree346143a54570451f8556b18f2837c5237cbb564c
parent8c2ac251ff0fb81e84b5f3fb2258b0dc81bdd4ee (diff)
downloadaur-3fc0459ea941c03b153c3115cb40f4433bd3bb51.tar.gz
Add missing variables and reorder them.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD33
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f46d677d244..452f3fbc4cad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = cabal2arch
pkgdesc = Create Arch Linux packages from Cabal packages.
pkgver = 1.2
pkgrel = 3
- url = http://github.com/archhaskell/
+ url = http://github.com/archhaskell/cabal2arch
arch = i686
arch = x86_64
license = BSD3
diff --git a/PKGBUILD b/PKGBUILD
index 574b68278063..9fbba48ae747 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,44 @@
# Maintainer : Damien Flament <damien.flament___at___gmx___dot___com>:w
# Contributor: Daniel Nagy <danielnagy___at___gmx___dot___de>
-# custom variables
-_hkgname=cabal2arch
-_licensefile=LICENSE
-
-# PKGBUILD options/directives
pkgname=cabal2arch
pkgver=1.2
pkgrel=3
pkgdesc="Create Arch Linux packages from Cabal packages."
-url="http://github.com/archhaskell/"
-license=("BSD3")
arch=('i686' 'x86_64')
-makedepends=("ghc" "haskell-archlinux" "haskell-cmdargs" "haskell-mtl")
+url="http://github.com/archhaskell/${pkgname}"
+license=("BSD3")
depends=()
-options=('strip' 'staticlibs' )
-source=("https://github.com/archhaskell/cabal2arch/archive/v1.2.tar.gz"
+makedepends=("ghc"
+ "haskell-archlinux"
+ "haskell-cmdargs"
+ "haskell-mtl")
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=('strip' 'staticlibs')
+install=
+source=("https://github.com/archhaskell/${pkgname}/archive/v${pkgver}.tar.gz"
'Make_build_pass.patch')
-
+noextract=()
md5sums=('68f08d55400a31927e63942f0ca5e462'
'b22ef0e1bcc21f81b4dbd34e9599d441')
+validpgpkeys=()
-# PKGBUILD functions
prepare() {
- cd ${_hkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
patch -Np1 -i "${srcdir}/Make_build_pass.patch"
}
build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
runhaskell Setup configure -O --prefix=/usr --docdir=/usr/share/doc/${pkgname}
runhaskell Setup build
}
package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
+ cd ${srcdir}/${pkgname}-${pkgver}
runhaskell Setup copy --destdir=${pkgdir}
}