summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:39:56 +0200
committerDaniel Nagy2015-06-08 19:39:56 +0200
commitd72e10de88f3847bb2b1b8f4d83e5f2aa78f03c1 (patch)
tree2dca73522ee1a8e70de050911d6028cbdedfbc47
downloadaur-d72e10de88f3847bb2b1b8f4d83e5f2aa78f03c1.tar.gz
import to aur4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb24d5f0e54f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cabal2arch
+ pkgdesc = Create Arch Linux packages from Cabal packages.
+ pkgver = 1.2
+ pkgrel = 2
+ url = http://github.com/archhaskell/
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ makedepends = ghc
+ makedepends = haskell-archlinux
+ makedepends = haskell-cmdargs
+ makedepends = haskell-mtl
+ options = strip
+ options = staticlibs
+ source = https://github.com/archhaskell/cabal2arch/archive/v1.2.tar.gz
+ sha1sums = 18936e2bafb6059f56b4814216ac5874ab54fe56
+
+pkgname = cabal2arch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8a40faa4925
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+# custom variables
+_hkgname=cabal2arch
+_licensefile=LICENSE
+
+# PKGBUILD options/directives
+pkgname=cabal2arch
+pkgver=1.2
+pkgrel=2
+pkgdesc="Create Arch Linux packages from Cabal packages."
+url="http://github.com/archhaskell/"
+license=("BSD3")
+arch=('i686' 'x86_64')
+makedepends=("ghc" "haskell-archlinux" "haskell-cmdargs" "haskell-mtl")
+depends=()
+options=('strip' 'staticlibs' )
+source=("https://github.com/archhaskell/cabal2arch/archive/v1.2.tar.gz")
+
+sha1sums=('18936e2bafb6059f56b4814216ac5874ab54fe56')
+
+# PKGBUILD functions
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --prefix=/usr --docdir=/usr/share/doc/${pkgname}
+ runhaskell Setup build
+}
+
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup copy --destdir=${pkgdir}
+}