summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 17:56:37 -0600
committernot_anonymous2015-07-05 17:56:37 -0600
commit63fe8f62b6473dd6f0b94dcdf50123513ae81a05 (patch)
tree143476cb7292f71d09265c3b0154e86bd91a6873
downloadaur-63fe8f62b6473dd6f0b94dcdf50123513ae81a05.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
-rw-r--r--cabanalyst.desktop16
-rw-r--r--cabanalyst.install11
-rw-r--r--cabanalyst.pngbin0 -> 1929 bytes
5 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f6bbbb88788
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cabanalyst
+ pkgdesc = Ham radio contesting - Cabrillo log editor
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://hamsoftware.org/old_index.html
+ install = cabanalyst.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ source = http://www.hamsoftware.org/cabanalyst_v1.0.tgz
+ source = cabanalyst.desktop
+ source = cabanalyst.png
+ md5sums = 60672327a5eaa6f597c24f8bce2cdff6
+ md5sums = 942b749b8ba86b43011389601a82bf76
+ md5sums = 0c5fc02db4577b3b1ffcc23e5c7a2b8e
+ sha256sums = 7df96eb87d248d73b364012e8d10885c98e29f6645a9155934f7f2f6cca64d5e
+ sha256sums = a8af24312399aff52d91dad72704b50b73443ab95320679a64e378e57db69e88
+ sha256sums = ae4886c24e08425d7a9d6c31290924f8b328d0b2fe59b3d0c0e94ecf4d62b039
+
+pkgname = cabanalyst
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2568144a6fb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=cabanalyst
+pkgver=1.0
+pkgrel=1
+pkgdesc="Ham radio contesting - Cabrillo log editor"
+arch=('i686' 'x86_64')
+url="http://hamsoftware.org/old_index.html"
+license=('GPL3')
+depends=('qt4')
+install=$pkgname.install
+source=(http://www.hamsoftware.org/${pkgname}_v$pkgver.tgz
+ $pkgname.desktop
+ $pkgname.png)
+
+build() {
+ cd "$srcdir/$pkgname/"
+ /usr/lib/qt4/bin/qmake
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -Dm 755 $srcdir/$pkgname/$pkgname $pkgdir/usr/bin/$pkgname
+
+ install -dm755 "${pkgdir}"/usr/share/doc/$pkgname
+ install -m644 testlog.log "${pkgdir}"/usr/share/doc/$pkgname
+
+ mkdir -p $pkgdir/usr/share/pixmaps
+ mkdir -p $pkgdir/usr/share/applications
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+}
+md5sums=('60672327a5eaa6f597c24f8bce2cdff6'
+ '942b749b8ba86b43011389601a82bf76'
+ '0c5fc02db4577b3b1ffcc23e5c7a2b8e')
+sha256sums=('7df96eb87d248d73b364012e8d10885c98e29f6645a9155934f7f2f6cca64d5e'
+ 'a8af24312399aff52d91dad72704b50b73443ab95320679a64e378e57db69e88'
+ 'ae4886c24e08425d7a9d6c31290924f8b328d0b2fe59b3d0c0e94ecf4d62b039')
diff --git a/cabanalyst.desktop b/cabanalyst.desktop
new file mode 100644
index 000000000000..750347a0ac0e
--- /dev/null
+++ b/cabanalyst.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=CabAnalyst
+Name[en_US]=CabAnalyst
+Comment=Cabrillo log editor
+Comment[en_US]=Cabrillo log editor
+Encoding=UTF-8
+Exec=cabanalyst
+Icon=cabanalyst.png
+MimeType=text/plain
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+Categories=Application;HamRadio
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/cabanalyst.install b/cabanalyst.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/cabanalyst.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/cabanalyst.png b/cabanalyst.png
new file mode 100644
index 000000000000..cb1d2bebba85
--- /dev/null
+++ b/cabanalyst.png
Binary files differ