summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Ortel2018-04-21 16:43:27 +0300
committerJulian Ortel2018-04-21 16:43:27 +0300
commit859f51720157779a777363fbb470730c5f7d7c5f (patch)
treecb6ee17d013f93d149c2bdac89e957ace39817a8
downloadaur-859f51720157779a777363fbb470730c5f7d7c5f.tar.gz
init
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD22
-rw-r--r--cacher.install19
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e33376d7ad30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = cacher
+ pkgdesc = Cacher is a code snippet library for professional developers. Use it to build a technical knowledge base for you and your team.
+ pkgver = 1.4.3
+ pkgrel = 1
+ url = http://www.cacher.io
+ install = cacher.install
+ arch = x86_64
+ license = Copyright © 2018 Penguin Labs
+ depends = alsa-lib
+ depends = atk
+ depends = cairo
+ depends = dbus
+ depends = desktop-file-utils
+ depends = electron
+ depends = expat
+ depends = fontconfig
+ depends = freetype2
+ depends = gconf
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk2
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk2
+ depends = libcups
+ depends = libnotify
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxrandr
+ depends = libxrender
+ depends = libxss
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = opera
+ depends = pango
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://cacher-download.nyc3.digitaloceanspaces.com/cacher_1.4.3_amd64.deb
+ sha512sums_x86_64 = 05f1f44487d48bdcf110bda2dc4fdb1d50a9680610e6e528b42deff81517f58eead8cb34201fb6394dc70e9a55e77882374978ea6f03710cc440307f02cd1d24
+
+pkgname = cacher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c36006d46b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: M3NIX
+# Contributor: M3NIX
+pkgname=cacher
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="Cacher is a code snippet library for professional developers. Use it to build a technical knowledge base for you and your team."
+arch=('x86_64')
+url="http://www.cacher.io"
+license=('Copyright © 2018 Penguin Labs')
+groups=('')
+depends=('alsa-lib' 'atk' 'cairo' 'dbus' 'desktop-file-utils' 'electron' 'expat' 'fontconfig' 'freetype2' 'gconf' 'gdk-pixbuf2' 'glib2' 'gtk2' 'hicolor-icon-theme' 'libappindicator-gtk2' 'libcups' 'libnotify' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nspr' 'nss' 'opera' 'pango')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://cacher-download.nyc3.digitaloceanspaces.com/cacher_1.4.3_amd64.deb")
+sha512sums_x86_64=('05f1f44487d48bdcf110bda2dc4fdb1d50a9680610e6e528b42deff81517f58eead8cb34201fb6394dc70e9a55e77882374978ea6f03710cc440307f02cd1d24')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+}
diff --git a/cacher.install b/cacher.install
new file mode 100644
index 000000000000..fdfc11226b87
--- /dev/null
+++ b/cacher.install
@@ -0,0 +1,19 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/Cacher/cacher' '/usr/bin/cacher'
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/cacher'
+ update-desktop-database -q
+}