summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTarn Burton2016-03-03 07:09:08 -0500
committerTarn Burton2016-03-03 07:09:08 -0500
commitc57229f6e56d26df910109beb8aede2517467c05 (patch)
treeadeefe78d2d067f51f25d7551f16a8a5a61df822
parentca92a3e1ce6d0caac48c53d13523b2b238b259d8 (diff)
downloadaur-c57229f6e56d26df910109beb8aede2517467c05.tar.gz
Cleaned up patch file.
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD2
-rw-r--r--package.patch88
3 files changed, 17 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a76d1f48f7a..b213551dfa0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Mar 2 23:22:56 UTC 2016
+# Thu Mar 3 12:08:42 UTC 2016
pkgbase = cadabra
pkgdesc = A computer algebra system designed specifically for the solution of problems encountered in field theory.
pkgver = 1.33
@@ -16,7 +16,7 @@ pkgbase = cadabra
source = http://cadabra.phi-sci.com/cadabra-1.33.tar.gz
source = package.patch
md5sums = cee8ae23c169958aba09b64e4ea479ce
- md5sums = c3ed39abb74ec433ce38ba99b7a60d4a
+ md5sums = 3346f2dcc00c4879417329e8bdfe350d
pkgname = cadabra
diff --git a/PKGBUILD b/PKGBUILD
index 7d68dbe21826..02c2dcda1ed8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ depends=('conlie' 'modglue' 'gmp' 'pcre') # for gui: 'gtkmm' 'dvipng' 'texlive'
install="$pkgname.install"
source=("http://cadabra.phi-sci.com/$pkgname-$pkgver.tar.gz" "package.patch")
md5sums=('cee8ae23c169958aba09b64e4ea479ce'
- 'c3ed39abb74ec433ce38ba99b7a60d4a')
+ '3346f2dcc00c4879417329e8bdfe350d')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/package.patch b/package.patch
index eca5b1c1ff95..1423b4ae2a68 100644
--- a/package.patch
+++ b/package.patch
@@ -1,6 +1,6 @@
diff -aur -bZwB cadabra-1.33.old/gui/Makefile.in cadabra-1.33/gui/Makefile.in
---- cadabra-1.33.old/gui/Makefile.in 2016-03-02 07:13:04.277941346 -0500
-+++ cadabra-1.33/gui/Makefile.in 2016-03-02 07:13:08.864580761 -0500
+--- cadabra-1.33.old/gui/Makefile.in 2016-03-03 07:02:23.193184730 -0500
++++ cadabra-1.33/gui/Makefile.in 2016-03-03 07:02:28.039825701 -0500
@@ -14,7 +14,7 @@
TIMESTAMP = -D"RELEASE=\"${RELEASE}\"" -D"DATETIME=\"`date | sed -e 's/ / /'`\"" -DHOSTNAME=\"`hostname`\"
@@ -20,8 +20,8 @@ diff -aur -bZwB cadabra-1.33.old/gui/Makefile.in cadabra-1.33/gui/Makefile.in
include .depend
diff -aur -bZwB cadabra-1.33.old/src/Makefile.in cadabra-1.33/src/Makefile.in
---- cadabra-1.33.old/src/Makefile.in 2016-03-02 07:13:04.277941346 -0500
-+++ cadabra-1.33/src/Makefile.in 2016-03-02 07:13:08.864580761 -0500
+--- cadabra-1.33.old/src/Makefile.in 2016-03-03 07:02:23.196518046 -0500
++++ cadabra-1.33/src/Makefile.in 2016-03-03 07:02:28.039825701 -0500
@@ -27,7 +27,7 @@
@@ -50,8 +50,8 @@ diff -aur -bZwB cadabra-1.33.old/src/Makefile.in cadabra-1.33/src/Makefile.in
include .depend
diff -aur -bZwB cadabra-1.33.old/src/manipulator.cc cadabra-1.33/src/manipulator.cc
---- cadabra-1.33.old/src/manipulator.cc 2016-03-02 07:13:04.277941346 -0500
-+++ cadabra-1.33/src/manipulator.cc 2016-03-02 07:14:09.617682321 -0500
+--- cadabra-1.33.old/src/manipulator.cc 2016-03-03 07:02:23.196518046 -0500
++++ cadabra-1.33/src/manipulator.cc 2016-03-03 07:02:28.039825701 -0500
@@ -283,7 +283,7 @@
if(getline_precut_buffer.size()==0 || getline_was_eof) {
std::string input_now;
@@ -62,80 +62,20 @@ diff -aur -bZwB cadabra-1.33.old/src/manipulator.cc cadabra-1.33/src/manipulator
getline_precut_buffer+=input_now;
}
diff -aur -bZwB cadabra-1.33.old/src/manipulator.hh cadabra-1.33/src/manipulator.hh
---- cadabra-1.33.old/src/manipulator.hh 2016-03-02 07:13:04.277941346 -0500
-+++ cadabra-1.33/src/manipulator.hh 2016-03-02 07:13:08.864580761 -0500
-@@ -21,17 +21,17 @@
- #ifndef manipulator_hh_
- #define manipulator_hh_
-
--#include "storage.hh"
- #include "algorithm.hh"
- #include "display.hh"
--#include <string>
--#include <map>
--#include <iostream>
-+#include "storage.hh"
+--- cadabra-1.33.old/src/manipulator.hh 2016-03-03 07:02:23.196518046 -0500
++++ cadabra-1.33/src/manipulator.hh 2016-03-03 07:03:56.486018858 -0500
+@@ -30,7 +30,7 @@
#include <fstream>
--#include <utility>
--#include <stack>
+ #include <utility>
+ #include <stack>
-#include <sigc++/object.h>
-+#include <iostream>
-+#include <map>
- #include <modglue/pipe.hh>
+#include <sigc++/sigc++.h>
-+#include <stack>
-+#include <string>
-+#include <utility>
+ #include <modglue/pipe.hh>
// These are initiated in main.cc
- extern std::ostream *real_txtout;
-@@ -65,8 +65,8 @@
- exit_exception();
- };
-
--
--/// Singleton object which pulls in data from the input streams, handles switching
-+/// Singleton object which pulls in data from the input streams, handles
-+/// switching
- /// between streams, feeds data to the parser, and calls the algorithm objects
- /// to perform action on the expression tree.
- class manipulator : public sigc::trackable {
-@@ -109,15 +109,18 @@
-
- std::stack<std::istream *> streamstack;
-
-- void output_comment(const std::string& comment) const; // wrap in xml nodes if necessary
-+ void output_comment(
-+ const std::string &comment) const; // wrap in xml nodes if necessary
- void output_status() const;
- void read_program_file();
-
-- /// Cleans up the stream at the top of streamstack. If it derives from ifstream,
-+ /// Cleans up the stream at the top of streamstack. If it derives from
-+ /// ifstream,
- /// will call close on it as well. Pops the stream off the stack.
- void cleanup_stream();
-
-- /// Replace \\argv[n] in the input with the n-th command line argument as stored
-+ /// Replace \\argv[n] in the input with the n-th command line argument as
-+ /// stored
- /// in the global cmdline_arguments vector.
- void replace_cmdline_args(std::string& oneline);
-
-@@ -140,7 +143,8 @@
- exptree::iterator apply_post_default_rules_(exptree::iterator);
- void extract_properties_(exptree::iterator);
- exptree::iterator run_procedure(exptree::iterator, long);
-- bool handle_external_commands_(exptree::iterator&, exptree::iterator, exptree::iterator&);
-+ bool handle_external_commands_(exptree::iterator &, exptree::iterator,
-+ exptree::iterator &);
- std::string texify(const std::string&) const;
-
- /// Class to hold information about a dynamically added algorithm class.
-Only in cadabra-1.33/src: manipulator.hh.orig
diff -aur -bZwB cadabra-1.33.old/src/modules/substitute.cc cadabra-1.33/src/modules/substitute.cc
---- cadabra-1.33.old/src/modules/substitute.cc 2016-03-02 07:13:04.277941346 -0500
-+++ cadabra-1.33/src/modules/substitute.cc 2016-03-02 07:13:56.064395400 -0500
+--- cadabra-1.33.old/src/modules/substitute.cc 2016-03-03 07:02:23.196518046 -0500
++++ cadabra-1.33/src/modules/substitute.cc 2016-03-03 07:02:28.039825701 -0500
@@ -876,7 +876,7 @@
}
std::string nm=*to_->name + fnd->first.begin()->name->substr(from_->name->size());