aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Linz2016-09-29 13:55:01 +0200
committerAndreas Linz2016-09-29 18:27:48 +0200
commitc9a959eb7f4f8532c4d769b8b1237f316109fee1 (patch)
tree6de395eb74251543fc7cb3c79a66fe71c4a06974
parentbeb33dfe1f46b109b85cdc291b8c3f1f9c1db78d (diff)
downloadaur-c9a959eb7f4f8532c4d769b8b1237f316109fee1.tar.gz
Patch caddy's systemd service file to reenable capabilities
This commit https://github.com/mholt/caddy/commit/3f83eccfbd7f553c593d8e89d173699fb4cd2b61 removed the capabilities which are required for caddy in Arch linux. Patch caddy's systemd service file to reenable capabilities This commit https://github.com/mholt/caddy/commit/3f83eccfbd7f553c593d8e89d173699fb4cd2b61 removed the capabilities which are required for caddy in Arch linux.
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7bfa1d60a69b..501214fd47eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,16 +17,15 @@ url="https://caddyserver.com"
license=('Apache')
provides=('caddy')
conflicts=('caddy' 'caddy-git' 'caddy-all-features')
-depends=('systemd>=229')
-makedepends=('patch')
+depends=('systemd>=229' 'patch')
md5sums_i686=('SKIP'
- 'bb3b2b3e58fe090a298e3d20b6f2597b')
+ '61c39378589e5c59314e7a157fbf9a53')
md5sums_x86_64=('SKIP'
- 'bb3b2b3e58fe090a298e3d20b6f2597b')
+ '61c39378589e5c59314e7a157fbf9a53')
md5sums_armv7h=('SKIP'
- 'bb3b2b3e58fe090a298e3d20b6f2597b')
+ '61c39378589e5c59314e7a157fbf9a53')
md5sums_aarch64=('SKIP'
- 'bb3b2b3e58fe090a298e3d20b6f2597b')
+ '61c39378589e5c59314e7a157fbf9a53')
install='caddy-full-bin.install'
# expand the feature array
@@ -35,6 +34,11 @@ printf -v _features '%s,' "${_features[@]}"
_features=${_features%,}
_url_prefix="https://caddyserver.com/download/build?os=linux&features=${_features}"
+prepare() {
+ msg2 "Patching systemd service file"
+ patch -Np1 -i "${srcdir}/caddy-systemd-service.patch" "${srcdir}/init/linux-systemd/caddy.service"
+}
+
source_i686=("caddy.tar.gz::http://bit.ly/2djygqB" "caddy-systemd-service.patch")
source_x86_64=("caddy.tar.gz::http://bit.ly/2daBvir" "caddy-systemd-service.patch")
source_armv7h=("caddy.tar.gz::http://bit.ly/2d99iES" "caddy-systemd-service.patch")