summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2018-05-11 23:36:52 +0800
committerIru Cai2018-05-11 23:36:52 +0800
commit00b51c5ca9ed4f0092b71fb4ce9372ed0f561ea6 (patch)
tree887ceef3b9587a4d7371ce3de5827a939e803405
parent75150cc8b0913a5217ac1e447d95ce57e483ad72 (diff)
downloadaur-00b51c5ca9ed4f0092b71fb4ce9372ed0f561ea6.tar.gz
update to Caddy 0.11.0, CGI 1.7
-rw-r--r--PKGBUILD14
-rw-r--r--noquic_aesni.patch41
2 files changed, 16 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72dd0c7536a8..1ff6e2dff9bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,16 +16,16 @@ fi
pkgname=caddy-with-cgi
_pkgbase=caddy
-pkgver=0.10.14
-_cgiver=1.6
-pkgrel=2
+pkgver=0.11.0
+_cgiver=1.7
+pkgrel=1
pkgdesc='HTTP/2 Web Server with Automatic HTTPS, with caddy-cgi plugin and gcc-go support'
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url='https://caddyserver.com'
license=('Apache')
backup=('etc/caddy/caddy.conf')
install='caddy.install'
-makedepends=('go>=1.9')
+makedepends=('go>=1.8')
provides=('caddy')
conflicts=('caddy')
source=("https://$_gopkgname/archive/v$pkgver/$_pkgbase-$pkgver.tar.gz"
@@ -37,14 +37,14 @@ source=("https://$_gopkgname/archive/v$pkgver/$_pkgbase-$pkgver.tar.gz"
'caddy.conf'
'noquic_aesni.patch'
'plugins.patch')
-sha256sums=('13feb836e85af3525b3e95f42635566f14d171edc9776881f59fbf61fa45d345'
- '7c5b82831f496a182f2631fac840fc0712b41afcbf4b6ce3d4e6a235eef88580'
+sha256sums=('81e593d258460a9f5c6b5a5f46890a08b6b1ce15f5c0fc7bcaf09826368c3a1a'
+ '3e31a26d162b3c24dc7ae960883f48a2df332d55f7fc75b73a1d30b1524d29f3'
'e679dd79fd92dc351fc190c7af529c73e3896986aaa6b7c0ae01e561398d6b85'
'6db7aec45e95bbbf770ce4d120a60d8e4992d2262a8ebf668521179279aa5ae7'
'69e25def317a6172011472bd060655142f3085a0c81392f8a7a9c42b6a58bbd9'
'bd4d912d083be176727882ccc1bbe577a27cc160db09238e5edc05ba458aebce'
'80520b80ccabf077a3269f6a1bf55faa3811ef5adce115131b35ef2044d37b64'
- 'aea16a7850fed36899a0134e564f59657169e338c51e55054d9553a7dee209de'
+ '0874307e09dff107ea8e1e6481ccef89363154696f30b79e0469f49e8d370d32'
'c8d56b2295e04720ae8fe9493a7931bb2dba5c568fbcae469887ac143bd6b934')
prepare() {
diff --git a/noquic_aesni.patch b/noquic_aesni.patch
index b0a1b90c3edc..cd246168a22c 100644
--- a/noquic_aesni.patch
+++ b/noquic_aesni.patch
@@ -1,5 +1,5 @@
diff --git a/caddyhttp/httpserver/server.go b/caddyhttp/httpserver/server.go
-index c3fbc66..01b3116 100644
+index 800f921..6b9f690 100644
--- a/caddyhttp/httpserver/server.go
+++ b/caddyhttp/httpserver/server.go
@@ -32,7 +32,6 @@ import (
@@ -10,7 +10,7 @@ index c3fbc66..01b3116 100644
"github.com/mholt/caddy"
"github.com/mholt/caddy/caddyhttp/staticfiles"
"github.com/mholt/caddy/caddytls"
-@@ -41,7 +40,6 @@ import (
+@@ -42,7 +41,6 @@ import (
// Server is the HTTP server implementation.
type Server struct {
Server *http.Server
@@ -18,7 +18,7 @@ index c3fbc66..01b3116 100644
listener net.Listener
listenerMu sync.Mutex
sites []*SiteConfig
-@@ -104,12 +102,6 @@ func NewServer(addr string, group []*SiteConfig) (*Server, error) {
+@@ -105,12 +103,6 @@ func NewServer(addr string, group []*SiteConfig) (*Server, error) {
// if TLS is enabled, make sure we prepare the Server accordingly
if s.Server.TLSConfig != nil {
@@ -31,7 +31,7 @@ index c3fbc66..01b3116 100644
// wrap the HTTP handler with a handler that does MITM detection
tlsh := &tlsHandler{next: s.Server.Handler}
s.Server.Handler = tlsh // this needs to be the "outer" handler when Serve() is called, for type assertion
-@@ -236,7 +228,6 @@ func makeHTTPServerWithTimeouts(addr string, group []*SiteConfig) *http.Server {
+@@ -237,7 +229,6 @@ func makeHTTPServerWithTimeouts(addr string, group []*SiteConfig) *http.Server {
func (s *Server) wrapWithSvcHeaders(previousHandler http.Handler) http.HandlerFunc {
return func(w http.ResponseWriter, r *http.Request) {
@@ -39,7 +39,7 @@ index c3fbc66..01b3116 100644
previousHandler.ServeHTTP(w, r)
}
}
-@@ -322,18 +313,11 @@ func (s *Server) Serve(ln net.Listener) error {
+@@ -323,18 +314,11 @@ func (s *Server) Serve(ln net.Listener) error {
if err == http.ErrServerClosed {
err = nil // not an error worth reporting since closing a server is intentional
}
@@ -59,7 +59,7 @@ index c3fbc66..01b3116 100644
}
diff --git a/caddyhttp/proxy/reverseproxy.go b/caddyhttp/proxy/reverseproxy.go
-index c528cf4..9f1dff3 100644
+index 4de24ea..a7eb9da 100644
--- a/caddyhttp/proxy/reverseproxy.go
+++ b/caddyhttp/proxy/reverseproxy.go
@@ -39,8 +39,6 @@ import (
@@ -71,7 +71,7 @@ index c528cf4..9f1dff3 100644
"github.com/mholt/caddy/caddyhttp/httpserver"
)
-@@ -246,13 +244,6 @@ func NewSingleHostReverseProxy(target *url.URL, without string, keepalive int, t
+@@ -245,13 +243,6 @@ func NewSingleHostReverseProxy(target *url.URL, without string, keepalive int, t
rp.Transport = &http.Transport{
Dial: socketDial(target.String(), timeout),
}
@@ -85,7 +85,7 @@ index c528cf4..9f1dff3 100644
} else if keepalive != http.DefaultMaxIdleConnsPerHost || strings.HasPrefix(target.Scheme, "srv") {
dialFunc := rp.dialer.Dial
if strings.HasPrefix(target.Scheme, "srv") {
-@@ -301,11 +292,6 @@ func (rp *ReverseProxy) UseInsecureTransport() {
+@@ -298,11 +289,6 @@ func (rp *ReverseProxy) UseInsecureTransport() {
// No http2.ConfigureTransport() here.
// For now this is only added in places where
// an http.Transport is actually created.
@@ -97,7 +97,7 @@ index c528cf4..9f1dff3 100644
}
}
-@@ -323,10 +309,6 @@ func (rp *ReverseProxy) ServeHTTP(rw http.ResponseWriter, outreq *http.Request,
+@@ -316,10 +302,6 @@ func (rp *ReverseProxy) ServeHTTP(rw http.ResponseWriter, outreq *http.Request,
rp.Director(outreq)
@@ -108,26 +108,3 @@ index c528cf4..9f1dff3 100644
res, err := transport.RoundTrip(outreq)
if err != nil {
return err
-diff --git a/caddytls/config.go b/caddytls/config.go
-index 80f1633..ae722d8 100644
---- a/caddytls/config.go
-+++ b/caddytls/config.go
-@@ -23,7 +23,6 @@ import (
- "net/url"
- "strings"
-
-- "github.com/codahale/aesnicheck"
- "github.com/mholt/caddy"
- "github.com/xenolf/lego/acmev2"
- )
-@@ -648,10 +647,6 @@ var defaultCiphersNonAESNI = []uint16{
- //
- // See https://github.com/mholt/caddy/issues/1674
- func getPreferredDefaultCiphers() []uint16 {
-- if aesnicheck.HasAESNI() {
-- return defaultCiphers
-- }
--
- // Return a cipher suite that prefers ChaCha20
- return defaultCiphersNonAESNI
- }