summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-06-08 20:32:33 +0300
committerArtem Vorotnikov2015-06-08 20:32:33 +0300
commiteaa90254aaeb3ac205068ac4c936795d0d36ef24 (patch)
tree096c8f4e0c3abcb33b1e12a92095b3e4a7bd9f4c
downloadaur-eaa90254aaeb3ac205068ac4c936795d0d36ef24.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
-rw-r--r--caelum-ogre-1.9.patch53
-rw-r--r--caelumplugin.patch21
-rw-r--r--libname.patch12
5 files changed, 152 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2c513670202
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = caelum
+ pkgdesc = Library for OGRE targeted to help create nice-looking atmospheric effects.
+ pkgver = 0.6.1
+ pkgrel = 3
+ url = http://www.ogre3d.org/tikiwiki/Caelum
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ depends = ogre
+ depends = cegui
+ depends = doxygen
+ depends = boost
+ provides = caelum
+ source = http://caelum.googlecode.com/files/caelum-0.6.1.zip
+ source = caelumplugin.patch
+ source = libname.patch
+ source = caelum-ogre-1.9.patch
+ sha512sums = e1f5a8d3992c7e45a5e70febdb962935c0fb31e8d84c4a6576f3aa757d15678ddca2f24fb9888a6806cbcfb4171a9c10e97714d7e7154a5fb98d5ac4078ddb98
+ sha512sums = cc446e97eceef568e23ef15cbd32b183b5bb54e859ba558b1703c8c668fbc92f3bb904ffe95fa604d77937e653c96c2b80234d77dec5977fdc3656442a09f266
+ sha512sums = c8e368ee203273e8cbfc7b8aa4b65e37e2a58275292bf061ccc15428f54f7da68e7de5d183626e008dd3a92fdd401ccb231d1c5ab98434878871b1ec453a2ba0
+ sha512sums = SKIP
+
+pkgname = caelum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a03ec7976414
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+# Contributor: egore911
+# Contributor: Falcata
+# Contributor: Jose Riha <jose1711 gmail com>
+
+pkgname=caelum
+pkgver=0.6.1
+pkgrel=3
+pkgdesc="Library for OGRE targeted to help create nice-looking atmospheric effects."
+arch=('i686' 'x86_64')
+url="http://www.ogre3d.org/tikiwiki/Caelum"
+depends=('ogre' 'cegui' 'doxygen' 'boost')
+makedepends=('cmake')
+provides=('caelum')
+license=('LGPL')
+source=(http://caelum.googlecode.com/files/caelum-${pkgver}.zip caelumplugin.patch libname.patch caelum-ogre-1.9.patch)
+sha512sums=('e1f5a8d3992c7e45a5e70febdb962935c0fb31e8d84c4a6576f3aa757d15678ddca2f24fb9888a6806cbcfb4171a9c10e97714d7e7154a5fb98d5ac4078ddb98'
+ 'cc446e97eceef568e23ef15cbd32b183b5bb54e859ba558b1703c8c668fbc92f3bb904ffe95fa604d77937e653c96c2b80234d77dec5977fdc3656442a09f266'
+ 'c8e368ee203273e8cbfc7b8aa4b65e37e2a58275292bf061ccc15428f54f7da68e7de5d183626e008dd3a92fdd401ccb231d1c5ab98434878871b1ec453a2ba0'
+ 'SKIP')
+
+build() {
+ cd ${srcdir}/caelum-${pkgver}
+ patch -p0 < ${srcdir}/caelumplugin.patch main/src/CaelumPlugin.cpp
+ patch -p0 < ${srcdir}/libname.patch
+ patch -p0 < ${srcdir}/caelum-ogre-1.9.patch
+
+ # get a clean build dir
+ [[ -d build ]] && rm -rf build
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+ make
+}
+
+package() {
+ cd ${srcdir}/caelum-${pkgver}/build
+ make DESTDIR=${pkgdir} install
+}
diff --git a/caelum-ogre-1.9.patch b/caelum-ogre-1.9.patch
new file mode 100644
index 000000000000..ec452eeefc2f
--- /dev/null
+++ b/caelum-ogre-1.9.patch
@@ -0,0 +1,53 @@
+--- main/include/CaelumPrerequisites.h Fri Sep 19 17:39:48 2014 +0300
++++ main/include/CaelumPrerequisites.h Thu Nov 06 13:02:20 2014 +0100
+@@ -52,7 +52,9 @@
+
+ // By default only compile type descriptors for scripting.
+ #ifndef CAELUM_TYPE_DESCRIPTORS
+- #if (OGRE_VERSION >= 0x00010600) && OGRE_USE_NEW_COMPILERS
++ #if (OGRE_VERSION >= 0x00010900)
++ #define CAELUM_TYPE_DESCRIPTORS 1
++ #elif (OGRE_VERSION >= 0x00010600) && OGRE_USE_NEW_COMPILERS
+ #define CAELUM_TYPE_DESCRIPTORS 1
+ #else
+ #define CAELUM_TYPE_DESCRIPTORS 0
+@@ -71,8 +73,8 @@
+ #if !(OGRE_VERSION > 0x00010600)
+ #error "Caelum script support requires Ogre 1.6."
+ #endif
+- #if !(OGRE_USE_NEW_COMPILERS)
+- #error "Caelum script support requires Ogre 1.6 with OGRE_USE_NEW_COMPILERS."
++ #if (OGRE_VERSION < 0x00010900) && !(OGRE_USE_NEW_COMPILERS)
++ #error "Caelum script support requires Ogre 1.6 with OGRE_USE_NEW_COMPILERS or 1.9."
+ #endif
+ #if !(CAELUM_TYPE_DESCRIPTORS)
+ #error "Caelum script support also requires type descriptors."
+
+--- main/src/CaelumPlugin.cpp Fri Sep 19 17:39:48 2014 +0300
++++ main/src/CaelumPlugin.cpp Thu Nov 06 13:02:20 2014 +0100
+@@ -134,7 +134,9 @@
+ assert (this->isInstalled () && "Must install CaelumPlugin before loading scripts");
+
+ // Fetch raw resource ptr. Attempt to support explicit resource groups currently in Ogre trunk.
+-#if OGRE_VERSION >= 0x00010700
++#if OGRE_VERSION >= 0x00010900
++ Ogre::ResourcePtr res = getPropScriptResourceManager ()->createOrRetrieve (objectName, groupName).first;
++#elif OGRE_VERSION >= 0x00010700
+ Ogre::ResourcePtr res = getPropScriptResourceManager ()->getByName (objectName, groupName);
+ #else
+ Ogre::ResourcePtr res = getPropScriptResourceManager ()->getByName (objectName);
+
+--- main/src/CaelumScriptTranslator.cpp Fri Sep 19 17:39:48 2014 +0300
++++ main/src/CaelumScriptTranslator.cpp Thu Nov 06 13:02:20 2014 +0100
+@@ -422,7 +422,11 @@
+ //LogManager::getSingleton ().logMessage (
+ // "Caelum: Saved " + objNode->cls + " name " + objNode->name + " as a resource");
+ PropScriptResourceManager* mgr = this->getResourceManager ();
++#if OGRE_VERSION >= 0x00010900
++ ResourcePtr resource = mgr->createResource (objNode->name, compiler->getResourceGroup());
++#else
+ ResourcePtr resource = mgr->create (objNode->name, compiler->getResourceGroup());
++#endif
+ resource->_notifyOrigin (objNode->file);
+ return;
+ }
diff --git a/caelumplugin.patch b/caelumplugin.patch
new file mode 100644
index 000000000000..ceed0ff753af
--- /dev/null
+++ b/caelumplugin.patch
@@ -0,0 +1,21 @@
+24c24,31
+< template<> Caelum::CaelumPlugin* Ogre::Singleton<Caelum::CaelumPlugin>::ms_Singleton = 0;
+---
+> // ms_Singleton was renamed to msSingleton in ogre 1.8
+> #if OGRE_VERSION_MINOR < 8
+> #define SINGLETON_MEMBER ms_Singleton
+> #else
+> #define SINGLETON_MEMBER msSingleton
+> #endif
+>
+> template<> Caelum::CaelumPlugin* Ogre::Singleton<Caelum::CaelumPlugin>::SINGLETON_MEMBER = 0;
+29c36
+< return ms_Singleton;
+---
+> return SINGLETON_MEMBER;
+33,34c40,41
+< assert (ms_Singleton);
+< return *ms_Singleton;
+---
+> assert (SINGLETON_MEMBER);
+> return *SINGLETON_MEMBER;
diff --git a/libname.patch b/libname.patch
new file mode 100644
index 000000000000..8eae8f946177
--- /dev/null
+++ b/libname.patch
@@ -0,0 +1,12 @@
+*** CMakeLists.txt.old 2012-01-05 16:05:50.000000000 +0100
+--- CMakeLists.txt 2013-01-13 14:57:23.000000000 +0100
+***************
+*** 81,86 ****
+--- 81,87 ----
+ SET(includedir "\${prefix}/include")
+ SET(PACKAGE_NAME "Caelum")
+ SET(PACKAGE_VERSION "${LIB_VERSION}")
++ SET(LIBNAME "Caelum")
+
+ # configuration of the config.h and PkgConfig
+ CONFIGURE_FILE(