summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortritonas002015-09-22 22:41:55 +0300
committertritonas002015-09-22 22:41:55 +0300
commit6cb9c952cf2dcaf41ab5bc260abb6eb16995a9ce (patch)
treecece2f078fb2868b86db140cb0e14e7063bee980
parentea36fd187c542fe20578eb61a0fac210c50681d9 (diff)
downloadaur-6cb9c952cf2dcaf41ab5bc260abb6eb16995a9ce.tar.gz
update/fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4711afd78205..329757fbf4dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = caelum-git
pkgdesc = Library for OGRE targeted at helping to create nice-looking atmospheric effects.
- pkgver = 0.6.1
- pkgrel = 4
+ pkgver = r3.e776a80
+ pkgrel = 1
url = http://www.ogre3d.org/tikiwiki/Caelum
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = caelum-git
depends = boost
provides = caelum
conflicts = caelum
- source = git+https://github.com/skybon/caelum
+ source = git+https://github.com/RigsOfRods/caelum
sha512sums = SKIP
pkgname = caelum-git
diff --git a/PKGBUILD b/PKGBUILD
index 661072492c7a..e1711363f162 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=caelum-git
-pkgver=0.6.1
-pkgrel=4
+pkgver=r3.e776a80
+pkgrel=1
pkgdesc="Library for OGRE targeted at helping to create nice-looking atmospheric effects."
arch=('i686' 'x86_64')
url="http://www.ogre3d.org/tikiwiki/Caelum"
@@ -9,11 +9,11 @@ makedepends=('cmake' 'git')
provides=('caelum')
conflicts=('caelum')
license=('LGPL')
-source=("git+https://github.com/skybon/caelum")
+source=("git+https://github.com/RigsOfRods/caelum")
sha512sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd ${srcdir}/caelum
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -23,15 +23,14 @@ build() {
# get a clean build dir
# [[ -d build ]] && rm -rf build
# mkdir build && cd build
- cd build
- cmake .. \
+ cmake . \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd ${srcdir}/caelum/build
+ cd ${srcdir}/caelum
make DESTDIR=${pkgdir} install
}