summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-05-18 20:14:45 +0000
committerDaniel Bermond2019-05-18 20:14:45 +0000
commitb3b9afd7a5b47358d1877585f4bd19067d8b9b00 (patch)
tree6eef0b0181378b9bc6d282f610326ee6de3e177c
parent4fd54b7682feb836d48c2ed8f6d94810a7754a7c (diff)
downloadaur-b3b9afd7a5b47358d1877585f4bd19067d8b9b00.tar.gz
Fix docs build. Update dependencies.
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD23
2 files changed, 30 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76214f9d403d..28d160a5172f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = caffe
pkgdesc = A deep learning framework made with expression, speed, and modularity in mind (cpu only)
pkgver = 1.0
- pkgrel = 14
+ pkgrel = 15
url = https://caffe.berkeleyvision.org/
arch = i686
arch = x86_64
@@ -9,6 +9,8 @@ pkgbase = caffe
makedepends = boost
makedepends = doxygen
makedepends = texlive-core
+ makedepends = texlive-latexextra
+ makedepends = ghostscript
depends = openblas
depends = lapack
depends = boost-libs
@@ -20,24 +22,24 @@ pkgbase = caffe
depends = leveldb
depends = lmdb
depends = python
- depends = cython
depends = python-numpy
- depends = python-scipy
- depends = python-matplotlib
- depends = ipython
- depends = python-h5py
- depends = python-networkx
- depends = python-nose
depends = python-pandas
- depends = python-dateutil
- depends = python-protobuf
- depends = python-gflags
- depends = python-yaml
- depends = python-pillow
- depends = python-six
- depends = python-leveldb
- depends = python-scikit-image
- depends = python-pydotplus
+ optdepends = cython
+ optdepends = python-scipy
+ optdepends = python-matplotlib
+ optdepends = ipython
+ optdepends = python-h5py
+ optdepends = python-networkx
+ optdepends = python-nose
+ optdepends = python-dateutil
+ optdepends = python-protobuf
+ optdepends = python-gflags
+ optdepends = python-yaml
+ optdepends = python-pillow
+ optdepends = python-six
+ optdepends = python-leveldb
+ optdepends = python-scikit-image
+ optdepends = python-pydotplus
provides = caffe-cpu
conflicts = caffe-cpu
replaces = caffe-cpu
diff --git a/PKGBUILD b/PKGBUILD
index 2287dbd63a49..d0d7a43174fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,25 @@
pkgname=caffe
pkgver=1.0
-pkgrel=14
+pkgrel=15
pkgdesc='A deep learning framework made with expression, speed, and modularity in mind (cpu only)'
arch=('i686' 'x86_64')
url='https://caffe.berkeleyvision.org/'
license=('BSD')
-depends=(
+depends=('openblas' 'lapack' 'boost-libs' 'protobuf' 'google-glog' 'gflags'
+ 'hdf5' 'opencv' 'leveldb' 'lmdb' 'python' 'python-numpy' 'python-pandas')
+optdepends=(
# official repositories:
- 'openblas' 'lapack' 'boost-libs' 'protobuf' 'google-glog' 'gflags'
- 'hdf5' 'opencv' 'leveldb' 'lmdb' 'python' 'cython'
- 'python-numpy' 'python-scipy' 'python-matplotlib' 'ipython'
- 'python-h5py' 'python-networkx' 'python-nose' 'python-pandas'
- 'python-dateutil' 'python-protobuf' 'python-gflags' 'python-yaml'
- 'python-pillow' 'python-six'
+ 'cython' 'python-scipy' 'python-matplotlib' 'ipython' 'python-h5py'
+ 'python-networkx' 'python-nose' 'python-dateutil' 'python-protobuf'
+ 'python-gflags' 'python-yaml' 'python-pillow' 'python-six'
# AUR:
'python-leveldb' 'python-scikit-image' 'python-pydotplus'
# NOTE:
# python-pydotplus (or python-pydot) is required by python executable 'draw_net.py'
# https://github.com/BVLC/caffe/blob/1.0/python/caffe/draw.py#L7-L22
)
-makedepends=('boost' 'doxygen' 'texlive-core')
+makedepends=('boost' 'doxygen' 'texlive-core' 'texlive-latexextra' 'ghostscript')
provides=('caffe-cpu')
conflicts=('caffe-cpu')
replaces=('caffe-cpu')
@@ -36,7 +35,7 @@ sha256sums=('71d3c9eb8a183150f965a465824d01fe82826c22505f7aa314f700ace03fa77f'
prepare() {
cp -af "${srcdir}/Makefile.config" "${srcdir}/${pkgname}-${pkgver}"
- # fix build with opencv 4.0
+ # fix build with opencv 4
cd "${pkgname}-${pkgver}"
patch -Np1 -i "${srcdir}/caffe-1.0-opencv4-fix.patch"
}
@@ -44,14 +43,14 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
- make all pycaffe
+ make all pycaffe test
rm -rf doxygen
make docs distribute
}
check() {
cd "${pkgname}-${pkgver}"
- make test runtest
+ make runtest
}
package() {