summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-05-18 20:14:30 +0000
committerDaniel Bermond2019-05-18 20:14:30 +0000
commit38284ed64ba6e56880a801670a2c971afa968348 (patch)
tree38cc25fa4e010e862de44d3db8b0f1f86473d9aa
parent53954ba06b361941cc971a55a9fed1fb1cd55815 (diff)
downloadaur-38284ed64ba6e56880a801670a2c971afa968348.tar.gz
Fix docs build. Update dependencies.
-rw-r--r--.SRCINFO49
-rw-r--r--Makefile.config7
-rw-r--r--PKGBUILD30
3 files changed, 46 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afc1741801c8..50fcfe99b6b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = caffe-cuda
- pkgdesc = A deep learning framework made with expression, speed, and modularity in mind (with cuda)
+ pkgdesc = A deep learning framework made with expression, speed, and modularity in mind (with cuda support)
pkgver = 1.0
- pkgrel = 6
+ pkgrel = 7
url = https://caffe.berkeleyvision.org/
arch = x86_64
license = BSD
- makedepends = gcc7
makedepends = boost
makedepends = doxygen
makedepends = texlive-core
+ makedepends = texlive-latexextra
+ makedepends = ghostscript
depends = openblas
depends = lapack
depends = boost-libs
@@ -19,35 +20,35 @@ pkgbase = caffe-cuda
depends = opencv
depends = leveldb
depends = lmdb
- depends = cuda
- depends = cudnn
- depends = nccl
depends = python
- depends = cython
depends = python-numpy
- depends = python-scipy
- depends = python-matplotlib
- depends = ipython
- depends = python-h5py
- depends = python-networkx
- depends = python-nose
depends = python-pandas
- depends = python-dateutil
- depends = python-protobuf
- depends = python-gflags
- depends = python-yaml
- depends = python-pillow
- depends = python-six
- depends = python-leveldb
- depends = python-scikit-image
- depends = python-pydotplus
+ depends = cuda
+ depends = cudnn
+ depends = nccl
+ optdepends = cython
+ optdepends = python-scipy
+ optdepends = python-matplotlib
+ optdepends = ipython
+ optdepends = python-h5py
+ optdepends = python-networkx
+ optdepends = python-nose
+ optdepends = python-dateutil
+ optdepends = python-protobuf
+ optdepends = python-gflags
+ optdepends = python-yaml
+ optdepends = python-pillow
+ optdepends = python-six
+ optdepends = python-leveldb
+ optdepends = python-scikit-image
+ optdepends = python-pydotplus
provides = caffe
conflicts = caffe
- source = caffe-cuda-1.0.tar.gz::https://github.com/BVLC/caffe/archive/1.0.tar.gz
+ source = caffe-1.0.tar.gz::https://github.com/BVLC/caffe/archive/1.0.tar.gz
source = Makefile.config
source = caffe-1.0-opencv4-fix.patch
sha256sums = 71d3c9eb8a183150f965a465824d01fe82826c22505f7aa314f700ace03fa77f
- sha256sums = e3e294f15f46ff46b7243297cb562cd5a5b11d540231eb2874d2c21588ceaf54
+ sha256sums = d022edfc85f43f0f094240ef4852fbd62eb60aab9792a674b259860253207314
sha256sums = 2072c8ca1393b53ef280a15c43af940cc9bf1419ae32b3d8a6541b10b8cb50e9
pkgname = caffe-cuda
diff --git a/Makefile.config b/Makefile.config
index 6e9768352630..a78432bd9c6c 100644
--- a/Makefile.config
+++ b/Makefile.config
@@ -7,15 +7,20 @@ USE_OPENCV := 1
USE_LEVELDB := 1
USE_LMDB := 1
OPENCV_VERSION := $(_OCVMAJ)
-CUSTOM_CXX := g++-7
+CUSTOM_CXX := g++
CUDA_DIR := /opt/cuda
CUDA_ARCH := -gencode arch=compute_30,code=sm_30 \
+ -gencode arch=compute_32,code=sm_32 \
-gencode arch=compute_35,code=sm_35 \
+ -gencode arch=compute_37,code=sm_37 \
-gencode arch=compute_50,code=sm_50 \
-gencode arch=compute_52,code=sm_52 \
+ -gencode arch=compute_53,code=sm_53 \
-gencode arch=compute_60,code=sm_60 \
-gencode arch=compute_61,code=sm_61 \
+ -gencode arch=compute_62,code=sm_62 \
-gencode arch=compute_70,code=sm_70 \
+ -gencode arch=compute_72,code=sm_72 \
-gencode arch=compute_75,code=sm_75 \
-gencode arch=compute_75,code=compute_75
BLAS := open
diff --git a/PKGBUILD b/PKGBUILD
index 06f397d8c2d3..05be88f4febe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,39 +3,39 @@
pkgname=caffe-cuda
_srcname=caffe
pkgver=1.0
-pkgrel=6
-pkgdesc='A deep learning framework made with expression, speed, and modularity in mind (with cuda)'
+pkgrel=7
+pkgdesc='A deep learning framework made with expression, speed, and modularity in mind (with cuda support)'
arch=('x86_64')
url='https://caffe.berkeleyvision.org/'
license=('BSD')
-depends=(
+depends=('openblas' 'lapack' 'boost-libs' 'protobuf' 'google-glog' 'gflags'
+ 'hdf5' 'opencv' 'leveldb' 'lmdb' 'python' 'python-numpy' 'python-pandas'
+ 'cuda' 'cudnn' 'nccl')
+optdepends=(
# official repositories:
- 'openblas' 'lapack' 'boost-libs' 'protobuf' 'google-glog' 'gflags'
- 'hdf5' 'opencv' 'leveldb' 'lmdb' 'cuda' 'cudnn' 'nccl' 'python'
- 'cython' 'python-numpy' 'python-scipy' 'python-matplotlib' 'ipython'
- 'python-h5py' 'python-networkx' 'python-nose' 'python-pandas'
- 'python-dateutil' 'python-protobuf' 'python-gflags' 'python-yaml'
- 'python-pillow' 'python-six'
+ 'cython' 'python-scipy' 'python-matplotlib' 'ipython' 'python-h5py'
+ 'python-networkx' 'python-nose' 'python-dateutil' 'python-protobuf'
+ 'python-gflags' 'python-yaml' 'python-pillow' 'python-six'
# AUR:
'python-leveldb' 'python-scikit-image' 'python-pydotplus'
# NOTE:
# python-pydotplus (or python-pydot) is required by python executable 'draw_net.py'
# https://github.com/BVLC/caffe/blob/1.0/python/caffe/draw.py#L7-L22
)
-makedepends=('gcc7' 'boost' 'doxygen' 'texlive-core')
+makedepends=('boost' 'doxygen' 'texlive-core' 'texlive-latexextra' 'ghostscript')
provides=('caffe')
conflicts=('caffe')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/BVLC/caffe/archive/${pkgver}.tar.gz"
+source=("${_srcname}-${pkgver}.tar.gz"::"https://github.com/BVLC/caffe/archive/${pkgver}.tar.gz"
'Makefile.config'
'caffe-1.0-opencv4-fix.patch')
sha256sums=('71d3c9eb8a183150f965a465824d01fe82826c22505f7aa314f700ace03fa77f'
- 'e3e294f15f46ff46b7243297cb562cd5a5b11d540231eb2874d2c21588ceaf54'
+ 'd022edfc85f43f0f094240ef4852fbd62eb60aab9792a674b259860253207314'
'2072c8ca1393b53ef280a15c43af940cc9bf1419ae32b3d8a6541b10b8cb50e9')
prepare() {
cp -af "${srcdir}/Makefile.config" "${srcdir}/${_srcname}-${pkgver}"
- # fix build with opencv 4.0
+ # fix build with opencv 4
cd "${_srcname}-${pkgver}"
patch -Np1 -i "${srcdir}/caffe-1.0-opencv4-fix.patch"
}
@@ -43,14 +43,14 @@ prepare() {
build() {
cd "${_srcname}-${pkgver}"
- make all pycaffe
+ make all pycaffe test
rm -rf doxygen
make docs distribute
}
check() {
cd "${_srcname}-${pkgver}"
- make test runtest
+ make runtest
}
package() {