summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-10-17 21:01:16 +0000
committerDaniel Bermond2018-10-17 21:01:16 +0000
commitde9fee70086a52973726b4f598d81977102ac662 (patch)
treea2ed1867d5220b0837f7e7ddf079268bcba8c72a
parent361fdf017ae10a5991df2a6fe5f893b85ac85cdf (diff)
downloadaur-de9fee70086a52973726b4f598d81977102ac662.tar.gz
Update conflicts. Cosmetic changes.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD34
2 files changed, 12 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ffa3c1a68cb..977094d977e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = caffe-cuda
pkgdesc = A deep learning framework made with expression, speed, and modularity in mind (with cuda)
pkgver = 1.0
- pkgrel = 3
+ pkgrel = 4
url = http://caffe.berkeleyvision.org/
arch = x86_64
license = BSD
@@ -43,12 +43,6 @@ pkgbase = caffe-cuda
depends = python-pydotplus
provides = caffe
conflicts = caffe
- conflicts = caffe-git
- conflicts = caffe-cuda-git
- conflicts = caffe-cpu
- conflicts = caffe-cpu-git
- conflicts = caffe2
- conflicts = caffe2-cuda
source = caffe-cuda-1.0.tar.gz::https://github.com/BVLC/caffe/archive/1.0.tar.gz
source = Makefile.config
sha256sums = 71d3c9eb8a183150f965a465824d01fe82826c22505f7aa314f700ace03fa77f
diff --git a/PKGBUILD b/PKGBUILD
index edc31d6930bb..7c1032db1b3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
pkgname=caffe-cuda
_srcname=caffe
pkgver=1.0
-pkgrel=3
+pkgrel=4
pkgdesc='A deep learning framework made with expression, speed, and modularity in mind (with cuda)'
arch=('x86_64')
url='http://caffe.berkeleyvision.org/'
@@ -24,8 +24,7 @@ depends=(
)
makedepends=('gcc7' 'boost' 'doxygen' 'texlive-core')
provides=('caffe')
-conflicts=('caffe' 'caffe-git' 'caffe-cuda-git' 'caffe-cpu' 'caffe-cpu-git'
- 'caffe2' 'caffe2-cuda')
+conflicts=('caffe')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/BVLC/caffe/archive/${pkgver}.tar.gz"
'Makefile.config')
sha256sums=('71d3c9eb8a183150f965a465824d01fe82826c22505f7aa314f700ace03fa77f'
@@ -66,50 +65,39 @@ prepare() {
build() {
cd "${_srcname}-${pkgver}"
- msg2 "Building target 'all'..."
- make all
-
- msg2 "Building target 'pycaffe'..."
- make pycaffe
-
- msg2 "Building target 'docs'..."
+ make all pycaffe
rm -rf doxygen
- make docs
-
- msg2 "Building target 'distribute'..."
- make distribute
+ make docs distribute
}
# uncomment this block if you want to run the checks/tests
#check() {
# cd "${_srcname}-${pkgver}"
-# msg2 "Building target 'test'..."
# make test
-# msg2 "Making target 'runtest'..."
# make runtest
#}
package() {
+ cd "${_srcname}-${pkgver}/distribute"
+
local _pythonver
_pythonver="$(python --version | awk '{ print $2 }' | grep -o '^[0-9]*\.[0-9]*')"
mkdir -p "$pkgdir"/usr/{bin,include,lib/python"$_pythonver"/site-packages,share/doc}
- cd "${_srcname}-${pkgver}/distribute"
-
# binaries
install -m755 bin/* "${pkgdir}/usr/bin"
# library
- cp -af lib/libcaffe.so* "${pkgdir}/usr/lib"
+ cp -a lib/libcaffe.so* "${pkgdir}/usr/lib"
chmod 755 "${pkgdir}/usr/lib"/libcaffe.so.*.*.*
# headers
- cp -af include "${pkgdir}/usr"
+ cp -a include "${pkgdir}/usr"
# python
install -m755 python/*.py "${pkgdir}/usr/bin"
- cp -af python/caffe "${pkgdir}/usr/lib/python${_pythonver}/site-packages"
+ cp -a python/caffe "${pkgdir}/usr/lib/python${_pythonver}/site-packages"
# proto
install -D -m644 proto/caffe.proto -t "${pkgdir}/usr/share/caffe"
@@ -117,7 +105,7 @@ package() {
cd "${srcdir}/${_srcname}-${pkgver}"
# docs
- cp -af doxygen/html "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -a doxygen/html "${pkgdir}/usr/share/doc/${pkgname}"
# license
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"