summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-09-03 12:35:40 -0300
committerDaniel Bermond2017-09-03 12:35:40 -0300
commit435b90090b81b61c5bba1daf352d295f9ba1097c (patch)
tree13f5f945423a7706b5ff93c191b1e90ebf82a30d
parent296c52abe14e0d0214e43153bc4a725ff06a6b82 (diff)
downloadaur-435b90090b81b61c5bba1daf352d295f9ba1097c.tar.gz
Removed NCCL support (it can be enabled by uncommenting the proper lines)
The newly released NCCL version 2 requires registration at the NVIDIA developer webiste and a manual download. As this breaks automated builds by AUR helpers, NCCL was disabled by default in this package. It can still be enabled by uncommenting the proper lines in the PKGBUILD file (instructions are at the top of the PKGBUILD file).
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f9a4009e7bd..3e40be16252b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 6 13:26:39 UTC 2017
+# Sun Sep 3 15:35:16 UTC 2017
pkgbase = caffe-git
pkgdesc = A deep learning framework made with expression, speed, and modularity in mind (git version, gpu enabled)
- pkgver = 1.0.r24.g86d451e96
+ pkgver = 1.0.r25.g1de4cebfb
pkgrel = 1
url = http://caffe.berkeleyvision.org/
arch = x86_64
@@ -39,7 +39,6 @@ pkgbase = caffe-git
depends = python-pillow
depends = python-six
depends = openblas-lapack
- depends = nccl
depends = python-leveldb
depends = python-scikit-image
depends = python-pydotplus
diff --git a/PKGBUILD b/PKGBUILD
index aff0bb12214d..5e1c66720d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,13 @@
# Contributor: Drew Noel <drewmnoel@gmail.com>
# Contributor: Jonathan Yantis
+# NOTE:
+# In order to build with NCCL support, uncomment the NCCL
+# lines in 'depends' and 'preprare()'.
+
pkgname=caffe-git
_srcname=caffe
-pkgver=1.0.r24.g86d451e96
+pkgver=1.0.r25.g1de4cebfb
pkgrel=1
pkgdesc="A deep learning framework made with expression, speed, and modularity in mind (git version, gpu enabled)"
arch=('x86_64')
@@ -20,8 +24,8 @@ depends=(
# AUR:
# required:
'openblas-lapack'
- # not required but enabled in build:
- 'nccl'
+ # not required:
+ # 'nccl'
#python:
'python-leveldb' 'python-scikit-image' 'python-pydotplus'
# NOTE:
@@ -45,7 +49,7 @@ prepare() {
sed -i '/USE_CUDNN/s/^#[[:space:]]//g' Makefile.config
# enable NCCL acceleration switch
- sed -i '/USE_NCCL/s/^#[[:space:]]//g' Makefile.config
+ # sed -i '/USE_NCCL/s/^#[[:space:]]//g' Makefile.config
# strictly enable I/O dependencies
sed -i '/USE_OPENCV/s/^#[[:space:]]//;/USE_OPENCV/s/0/1/' Makefile.config