summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew Noel2016-05-12 07:46:22 -0400
committerDrew Noel2016-05-12 07:50:03 -0400
commit492a04a909d362a3ce26eaa33ce303fadd2fbbf5 (patch)
tree72f34660980dd063887b404383f6596522577f7a
parentd095be999e39d83dc425aa4a8e44d0cc8565a388 (diff)
downloadaur-492a04a909d362a3ce26eaa33ce303fadd2fbbf5.tar.gz
Fix maintainer, update NVCC flag fixes
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile.config4
-rw-r--r--PKGBUILD6
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1b96e6b8417..03a40e3a1179 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = caffe-git
pkgdesc = A fast framework for deep learning built in C++ for speed with a Python 2 interface
- pkgver = rc3.r120.gb86b0ae
+ pkgver = rc3.r152.g9c46289
pkgrel = 1
url = https://github.com/BVLC/caffe
arch = x86_64
@@ -50,7 +50,7 @@ pkgbase = caffe-git
source = Makefile.config
sha256sums = SKIP
sha256sums = c12ddbd524c1b5871cb42a8775cf17a3ef86ae8a859837a6c6c4e2c19deca3d5
- sha256sums = ac0195943510f1dfed85991958455cba6a36058e93f74ad4da0befb6fae84bd5
+ sha256sums = 91ac4b31b72c9c6fb8b1242c945d8caf32f1876ef4befa3c81b7d19940b6a143
pkgname = caffe-git
diff --git a/Makefile.config b/Makefile.config
index 2d1a0713f463..c7cf4657b575 100644
--- a/Makefile.config
+++ b/Makefile.config
@@ -62,8 +62,8 @@ WITH_PYTHON_LAYER := 1
INCLUDE_DIRS := $(PYTHON_INCLUDE) /usr/include
LIBRARY_DIRS := $(PYTHON_LIB) /usr/lib
-# Fix NVCC __float128 (thanks @mjal)
-NVCCFLAGS=-D__STRICT_ANSI__
+# Fix NVCC on GCC 6.x (thanks @ooxxcc!)
+NVCCFLAGS=-Xcompiler -std=c++98
BUILD_DIR := build
DISTRIBUTE_DIR := distribute
diff --git a/PKGBUILD b/PKGBUILD
index 680dc591c5b1..d7c14643835f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: jyantis <yantis@yantis.net>
+# Maintainer: Drew Noel <drewmnoel@gmail.com>
pkgname=caffe-git
-pkgver=rc3.r120.gb86b0ae
+pkgver=rc3.r152.g9c46289
pkgrel=1
pkgdesc='A fast framework for deep learning built in C++ for speed with a Python 2 interface'
arch=(x86_64)
@@ -47,7 +47,7 @@ provides=('caffe' 'pycaffe' 'python2-pycaffe' )
conflicts=('caffe' 'pycaffe' 'python2-pycaffe' 'pycaffe-git' 'python2-pycaffe-git')
sha256sums=('SKIP'
'c12ddbd524c1b5871cb42a8775cf17a3ef86ae8a859837a6c6c4e2c19deca3d5'
- 'ac0195943510f1dfed85991958455cba6a36058e93f74ad4da0befb6fae84bd5')
+ '91ac4b31b72c9c6fb8b1242c945d8caf32f1876ef4befa3c81b7d19940b6a143')
pkgver() {
cd caffe