summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Anderson2018-10-12 08:56:53 +0100
committerAndrew Anderson2018-10-12 08:56:53 +0100
commit01b7a6bbbbf46783fc7b7a5d30fba8758194f545 (patch)
tree1bf655a63375ed6cb516ce467fd7797193380bab
downloadaur-01b7a6bbbbf46783fc7b7a5d30fba8758194f545.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD41
2 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..850ab42c7d86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = caffe-opencl-slim-git
+ pkgdesc = A slimmed-down build of Caffe based on caffe-opencl-git
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://caffe.berkeleyvision.org/
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = boost-libs
+ depends = protobuf
+ depends = google-glog
+ depends = gflags
+ depends = python
+ depends = boost
+ depends = cython
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-matplotlib
+ depends = ipython
+ depends = python-networkx
+ depends = python-nose
+ depends = python-pandas
+ depends = python-dateutil
+ depends = python-protobuf
+ depends = python-gflags
+ depends = python-yaml
+ depends = python-pillow
+ depends = python-six
+ depends = opencl-driver
+ depends = openblas-lapack
+ depends = python-scikit-image
+ depends = viennacl
+ provides = caffe
+ conflicts = caffe
+ conflicts = caffe-git
+ conflicts = caffe-cpu-git
+ conflicts = caffe-dr-git
+ conflicts = caffe-mnc-dr-git
+ conflicts = caffe-cpu
+ conflicts = caffe2
+ conflicts = caffe2-git
+ conflicts = caffe2-cpu
+ conflicts = caffe2-cpu-git
+ conflicts = caffe-opencl-git
+ source = caffe::git+https://github.com/BVLC/caffe#branch=opencl
+ sha256sums = SKIP
+
+pkgname = caffe-opencl-slim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b033f2e9e265
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Andrew Anderson <aanderso at t c d dot ie>
+pkgname=caffe-opencl-slim-git
+_srcname=caffe
+pkgver=1.0
+pkgrel=1
+pkgdesc="A slimmed-down build of Caffe based on caffe-opencl-git"
+arch=('x86_64')
+url="http://caffe.berkeleyvision.org/"
+license=('BSD')
+depends=(
+ 'boost-libs' 'protobuf' 'google-glog' 'gflags'
+ 'python' 'boost' 'cython' 'python-numpy' 'python-scipy'
+ 'python-matplotlib' 'ipython' 'python-networkx' 'python-nose'
+ 'python-pandas' 'python-dateutil' 'python-protobuf' 'python-gflags'
+ 'python-yaml' 'python-pillow' 'python-six' 'opencl-driver'
+ 'openblas-lapack' 'python-scikit-image' 'viennacl'
+)
+makedepends=('cmake')
+provides=('caffe')
+conflicts=('caffe' 'caffe-git' 'caffe-cpu-git' 'caffe-dr-git' 'caffe-mnc-dr-git' 'caffe-cpu'
+ 'caffe2' 'caffe2-git' 'caffe2-cpu' 'caffe2-cpu-git' 'caffe-opencl-git')
+source=("${_srcname}"::"git+https://github.com/BVLC/${_srcname}#branch=opencl")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${_srcname}"
+ mkdir -p build
+ cd build
+ CMAKE_PARALLEL_LEVEL=`grep processor /proc/cpuinfo | wc -l` cmake -DBUILD_docs=OFF -DUSE_LIBDNN=OFF -DUSE_CUDNN=OFF -DUSE_OPENCV=OFF -DUSE_LEVELDB=OFF -DUSE_LMDB=OFF -DUSE_HDF5=OFF -DBLAS=Open -D python_version=3 -DCMAKE_INSTALL_PREFIX:PATH=${pkgdir}/usr -DCMAKE_INSTALL_LIBDIR=lib ..
+}
+
+build() {
+ cd "${_srcname}/build"
+ make -j`grep processor /proc/cpuinfo | wc -l` clean all
+}
+
+package() {
+ cd "${_srcname}/build"
+ make install
+ install -m644 ../LICENSE ${pkgdir}/usr/share/Caffe
+}