summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Anderson2018-10-12 09:36:52 +0100
committerAndrew Anderson2018-10-12 09:36:52 +0100
commit56cae31f9dbef27e1891dcdf8064fc059e93ea5d (patch)
tree4b1d95d34f1ae8484ec552fc0180cc9eb9dcf4d9
parent01b7a6bbbbf46783fc7b7a5d30fba8758194f545 (diff)
downloadaur-56cae31f9dbef27e1891dcdf8064fc059e93ea5d.tar.gz
Fix boost stuff
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--dependencies.patch23
3 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 850ab42c7d86..a547d7eaf6cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = caffe-opencl-slim-git
pkgdesc = A slimmed-down build of Caffe based on caffe-opencl-git
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = http://caffe.berkeleyvision.org/
arch = x86_64
license = BSD
@@ -43,7 +43,9 @@ pkgbase = caffe-opencl-slim-git
conflicts = caffe2-cpu-git
conflicts = caffe-opencl-git
source = caffe::git+https://github.com/BVLC/caffe#branch=opencl
+ source = dependencies.patch
sha256sums = SKIP
+ sha256sums = 7ddb59109d7df3889641eaa4769e6b9e82f96f623b200ecfd8ade7ecfe04f95f
pkgname = caffe-opencl-slim-git
diff --git a/PKGBUILD b/PKGBUILD
index b033f2e9e265..215ffe42b3d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=caffe-opencl-slim-git
_srcname=caffe
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A slimmed-down build of Caffe based on caffe-opencl-git"
arch=('x86_64')
url="http://caffe.berkeleyvision.org/"
@@ -19,8 +19,10 @@ makedepends=('cmake')
provides=('caffe')
conflicts=('caffe' 'caffe-git' 'caffe-cpu-git' 'caffe-dr-git' 'caffe-mnc-dr-git' 'caffe-cpu'
'caffe2' 'caffe2-git' 'caffe2-cpu' 'caffe2-cpu-git' 'caffe-opencl-git')
-source=("${_srcname}"::"git+https://github.com/BVLC/${_srcname}#branch=opencl")
-sha256sums=('SKIP')
+source=("${_srcname}"::"git+https://github.com/BVLC/${_srcname}#branch=opencl"
+ 'dependencies.patch')
+sha256sums=('SKIP'
+ '7ddb59109d7df3889641eaa4769e6b9e82f96f623b200ecfd8ade7ecfe04f95f')
prepare() {
cd "${_srcname}"
diff --git a/dependencies.patch b/dependencies.patch
new file mode 100644
index 000000000000..b37affd0ac62
--- /dev/null
+++ b/dependencies.patch
@@ -0,0 +1,23 @@
+--- Dependencies.cmake 2018-08-11 16:43:41.986780859 +0200
++++ Dependencies.cmake.new 2018-08-11 16:48:27.581959509 +0200
+@@ -345,7 +345,7 @@
+ # Find the matching boost python implementation
+ set(version ${PYTHONLIBS_VERSION_STRING})
+
+- STRING( REGEX REPLACE "[^0-9]" "" boost_py_version ${version} )
++ STRING( REGEX MATCH "[0-9]" boost_py_version ${version} )
+ find_package(Boost 1.46 COMPONENTS "python-py${boost_py_version}")
+ set(Boost_PYTHON_FOUND ${Boost_PYTHON-PY${boost_py_version}_FOUND})
+
+@@ -356,6 +356,11 @@
+ find_package(Boost 1.46 COMPONENTS "python-py${boost_py_version}")
+ set(Boost_PYTHON_FOUND ${Boost_PYTHON-PY${boost_py_version}_FOUND})
+
++ if(NOT Boost_PYTHON_FOUND)
++ find_package(Boost 1.46 COMPONENTS "python${boost_py_version}")
++ set(Boost_PYTHON_FOUND ${Boost_PYTHON${boost_py_version}_FOUND})
++ endif()
++
+ STRING( REGEX MATCHALL "([0-9.]+).[0-9]+" has_more_version ${version} )
+ if("${has_more_version}" STREQUAL "")
+ break()