summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-11-20 23:41:39 +0000
committerPeter Babič2021-11-23 19:08:36 +0100
commit3a61bba8541b582d55d7bda7969a1d85dc9665ea (patch)
tree3811d18dcb528986fbf7247754a4fe579008c4e0
parente2b1b80b7c46213c1701051ce2ea018818f21089 (diff)
downloadaur-3a61bba8541b582d55d7bda7969a1d85dc9665ea.tar.gz
Update Makefile for python 3.8. Drop i686 arch. Cosmetic changes.
-rw-r--r--.SRCINFO5
-rw-r--r--Makefile.config4
-rw-r--r--PKGBUILD33
3 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28d160a5172f..0219324f133a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = caffe
pkgdesc = A deep learning framework made with expression, speed, and modularity in mind (cpu only)
pkgver = 1.0
- pkgrel = 15
+ pkgrel = 16
url = https://caffe.berkeleyvision.org/
- arch = i686
arch = x86_64
license = BSD
makedepends = boost
@@ -47,7 +46,7 @@ pkgbase = caffe
source = Makefile.config
source = caffe-1.0-opencv4-fix.patch
sha256sums = 71d3c9eb8a183150f965a465824d01fe82826c22505f7aa314f700ace03fa77f
- sha256sums = 78137e80f764f51c0d4eeed5ce566f3745614b572b481c50197199291d34e2cd
+ sha256sums = d2a96f1cc984a2258b9f44a9dec8ec994796bd80f5f29b8f7bbb9a9de9f2f19b
sha256sums = 2072c8ca1393b53ef280a15c43af940cc9bf1419ae32b3d8a6541b10b8cb50e9
pkgname = caffe
diff --git a/Makefile.config b/Makefile.config
index 9a7b0d741472..9df4cf1d2a77 100644
--- a/Makefile.config
+++ b/Makefile.config
@@ -10,8 +10,8 @@ OPENCV_VERSION := $(_OCVMAJ)
BLAS := open
BLAS_INCLUDE := /usr/include
BLAS_LIB := /usr/lib
-PYTHON_LIBRARIES := boost_python$(_PYMAJ) python$(_PYVER)m
-PYTHON_INCLUDE := /usr/include/python$(_PYVER)m \
+PYTHON_LIBRARIES := boost_python$(_PYMAJ) python$(_PYVER)
+PYTHON_INCLUDE := /usr/include/python$(_PYVER) \
/usr/lib/python$(_PYVER)/site-packages/numpy/core/include
PYTHON_LIB := /usr/lib
WITH_PYTHON_LAYER := 1
diff --git a/PKGBUILD b/PKGBUILD
index d0d7a43174fa..2af0fab1bcff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Micah Chambers <micahc.vt@gmail.com>
pkgname=caffe
pkgver=1.0
-pkgrel=15
+pkgrel=16
pkgdesc='A deep learning framework made with expression, speed, and modularity in mind (cpu only)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://caffe.berkeleyvision.org/'
license=('BSD')
depends=('openblas' 'lapack' 'boost-libs' 'protobuf' 'google-glog' 'gflags'
@@ -29,37 +29,34 @@ source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/BVLC/caffe/archive/${
'Makefile.config'
'caffe-1.0-opencv4-fix.patch')
sha256sums=('71d3c9eb8a183150f965a465824d01fe82826c22505f7aa314f700ace03fa77f'
- '78137e80f764f51c0d4eeed5ce566f3745614b572b481c50197199291d34e2cd'
+ 'd2a96f1cc984a2258b9f44a9dec8ec994796bd80f5f29b8f7bbb9a9de9f2f19b'
'2072c8ca1393b53ef280a15c43af940cc9bf1419ae32b3d8a6541b10b8cb50e9')
prepare() {
- cp -af "${srcdir}/Makefile.config" "${srcdir}/${pkgname}-${pkgver}"
+ cp -af Makefile.config "${pkgname}-${pkgver}"
# fix build with opencv 4
- cd "${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/caffe-1.0-opencv4-fix.patch"
+ # https://github.com/BVLC/caffe/pull/6625
+ patch -d "${pkgname}-${pkgver}" -Np1 -i "${srcdir}/caffe-1.0-opencv4-fix.patch"
}
build() {
- cd "${pkgname}-${pkgver}"
-
- make all pycaffe test
- rm -rf doxygen
- make docs distribute
+ make -C "${pkgname}-${pkgver}" all pycaffe test
+ rm -rf "${pkgname}-${pkgver}/doxygen"
+ make -C "${pkgname}-${pkgver}" docs distribute
}
check() {
- cd "${pkgname}-${pkgver}"
- make runtest
+ make -C "${pkgname}-${pkgver}" runtest
}
package() {
cd "${pkgname}-${pkgver}/distribute"
- local _pythonver
- _pythonver="$(python -c 'import sys; print("%s.%s" %sys.version_info[0:2])')"
+ local _pyver
+ _pyver="$(python -c 'import sys; print("%s.%s" %sys.version_info[0:2])')"
- mkdir -p "$pkgdir"/usr/{bin,include,lib/python"$_pythonver"/site-packages,share/doc}
+ mkdir -p "$pkgdir"/usr/{bin,include,lib/python"$_pyver"/site-packages,share/doc}
# binaries
install -m755 bin/* "${pkgdir}/usr/bin"
@@ -73,7 +70,7 @@ package() {
# python
install -m755 python/*.py "${pkgdir}/usr/bin"
- cp -a python/caffe "${pkgdir}/usr/lib/python${_pythonver}/site-packages"
+ cp -a python/caffe "${pkgdir}/usr/lib/python${_pyver}/site-packages"
# proto
install -D -m644 proto/caffe.proto -t "${pkgdir}/usr/share/caffe"