summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-07-20 23:33:32 -0300
committerPeter Babič2021-11-23 19:08:36 +0100
commitc8920a86cd74f9a70688ff7f6092faea919d1c3a (patch)
tree898a2854699b95fc8dc88940262ce5c9252ebd06
parentef6ec6e3d5d78497beebdae79bb92e58230928ba (diff)
downloadaur-c8920a86cd74f9a70688ff7f6092faea919d1c3a.tar.gz
Fix build flags to work with gcc5
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1d3f5618216..1d9e55a83661 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 30 18:50:39 UTC 2017
+# Fri Jul 21 02:33:27 UTC 2017
pkgbase = caffe
pkgdesc = A deep learning framework made with expression, speed, and modularity in mind (gpu enabled)
pkgver = 1.0
- pkgrel = 3
+ pkgrel = 4
url = http://caffe.berkeleyvision.org/
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 9f07eaa61d7e..2af720d090f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=caffe
pkgver=1.0
-pkgrel=3
+pkgrel=4
pkgdesc="A deep learning framework made with expression, speed, and modularity in mind (gpu enabled)"
arch=('x86_64')
url="http://caffe.berkeleyvision.org/"
@@ -91,14 +91,21 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
+ _gcc5_cxxflags="$(printf '%s' "$CXXFLAGS" | sed 's/-fno-plt//')"
+ _gcc5_cflags="$( printf '%s' "$CFLAGS" | sed 's/-fno-plt//')"
+
msg2 "Building target 'all'..."
- make all
+ CXXFLAGS="$_gcc5_cxxflags" CFLAGS="$_gcc5_cflags" make all
+
msg2 "Building target 'pycaffe'..."
- make pycaffe
+ CXXFLAGS="$_gcc5_cxxflags" CFLAGS="$_gcc5_cflags" make pycaffe
+
msg2 "Building target 'docs'..."
- make docs
+ rm -rf doxygen
+ CXXFLAGS="$_gcc5_cxxflags" CFLAGS="$_gcc5_cflags" make docs
+
msg2 "Building target 'distribute'..."
- make distribute
+ CXXFLAGS="$_gcc5_cxxflags" CFLAGS="$_gcc5_cflags" make distribute
}
# uncomment this block if you want to run the checks/tests