summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-06-29 19:14:01 +0000
committerDaniel Bermond2019-06-29 19:14:01 +0000
commit94d52907600d12dd050c417b5900ff76ac8df76b (patch)
treeacc03afbb3a09044208158cf50447197840ba812
parent51c53331361eaadeef73e3c514a0a3c0fc83d65f (diff)
downloadaur-94d52907600d12dd050c417b5900ff76ac8df76b.tar.gz
Fix conflicts
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e86c2dd5f46..4687c566775a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = caffe2
pkgdesc = A new lightweight, modular, and scalable deep learning framework
pkgver = 0.8.2_1.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://caffe2.ai/
arch = x86_64
license = BSD
@@ -100,6 +100,7 @@ pkgbase = caffe2
pkgname = caffe2
pkgdesc = A new lightweight, modular, and scalable deep learning framework (cpu only)
provides = caffe2-cpu
+ conflicts = python-pytorch
conflicts = caffe2-cpu
replaces = caffe2-cpu
@@ -118,5 +119,6 @@ pkgname = caffe2-cuda
depends = cudnn
depends = nccl
provides = caffe2
+ conflicts = python-pytorch
conflicts = caffe2
diff --git a/PKGBUILD b/PKGBUILD
index ae170dc19bab..3e276977b16f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=caffe2
pkgname=('caffe2' 'caffe2-cuda')
_pytorchver=1.1.0 # pytorch stable release version
pkgver="0.8.2_${_pytorchver}"
-pkgrel=2
+pkgrel=3
pkgdesc='A new lightweight, modular, and scalable deep learning framework'
arch=('x86_64')
url='https://caffe2.ai/'
@@ -194,7 +194,7 @@ package_caffe2-cuda() {
pkgdesc+=' (with cuda support)'
depends+=('cuda' 'cudnn' 'nccl')
provides=('caffe2')
- conflicts=('caffe2')
+ conflicts+=('caffe2')
cd pytorch/build-cuda
@@ -204,7 +204,7 @@ package_caffe2-cuda() {
package_caffe2() {
pkgdesc+=' (cpu only)'
provides=('caffe2-cpu')
- conflicts=('caffe2-cpu')
+ conflicts+=('caffe2-cpu')
replaces=('caffe2-cpu')
cd pytorch/build-cpu-only