summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-09-13 15:56:10 -0300
committerDaniel Bermond2017-09-13 15:56:10 -0300
commitbcaab98116c9acfbab408051f1687857cfb1b66f (patch)
tree5e0a84ece5c8d72236b5ce24245fec51dfcf82a4
parentb40c59c50be3e8c5f1e0fe3b06dac1416a495d46 (diff)
downloadaur-bcaab98116c9acfbab408051f1687857cfb1b66f.tar.gz
Fix cmake error
This required the removal off gloo support. Hopefully gloo can be enabled in a future caffe2 version, since it is working on git master (caffe2-git). Also removed the now unneeded nccl cmake lines.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e435bd9d6e41..5a5d17718f79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 3 16:45:36 UTC 2017
+# Wed Sep 13 18:55:48 UTC 2017
pkgbase = caffe2
pkgdesc = A new lightweight, modular, and scalable deep learning framework (gpu enabled)
pkgver = 0.8.1
- pkgrel = 4
+ pkgrel = 5
url = http://caffe2.ai/
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index d36d159eb354..61ed52fbc0ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ _protobuf_version='3.1.0' # commit 'a428e42072765993ff674fda72863c9f1aa2d268' is
pkgname=caffe2
pkgver=0.8.1
-pkgrel=4
+pkgrel=5
pkgdesc='A new lightweight, modular, and scalable deep learning framework (gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -176,9 +176,6 @@ build() {
-DCUDNN_ROOT_DIR:PATH='/opt/cuda' \
\
-DGLOO_STATIC_OR_SHARED:STRING='STATIC' \
- -DNCCL_INCLUDE_DIR:PATH='/opt/cuda/include' \
- -DNCCL_LIBRARY:FILEPATH='/opt/cuda/lib64/libnccl.so' \
- -DNCCL_ROOT_DIR:PATH='/opt/cuda' \
\
-DOpenCV_DIR:PATH='/usr/share/OpenCV' \
\
@@ -190,7 +187,7 @@ build() {
-DUSE_CUDA:BOOL='ON' \
-DUSE_GFLAGS:BOOL='ON' \
-DUSE_GLOG:BOOL='ON' \
- -DUSE_GLOO:BOOL='ON' \
+ -DUSE_GLOO:BOOL='OFF' \
-DUSE_LEVELDB:BOOL='ON' \
-DUSE_LITE_PROTO:BOOL='OFF' \
-DUSE_LMDB:BOOL='ON' \