summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-09-30 13:14:55 +0000
committerDaniel Bermond2018-09-30 13:34:38 +0000
commit8a10c8d5b5d39510532bbca3b9d8a9ec6d873256 (patch)
tree8219629ee58bc9ed5538cc5ea129290f6aaec1e1
parentebc331b492350e2c68f92aa9b3a809c01480ce21 (diff)
downloadaur-8a10c8d5b5d39510532bbca3b9d8a9ec6d873256.tar.gz
Update method for choosing the cuda architecture to match upstream
The current method for choosing the cuda architecture in the build is by using the TORCH_CUDA_ARCH_LIST environment variable. According to comments in the upstream source code, in the future this method will change to a cmake option of the same name. References ---------- https://github.com/pytorch/pytorch/blob/93ecf4d72ada7fd6cbcf9ec582ecb0e37344bc7c/cmake/public/utils.cmake#L165-L190
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98dab039f528..c6aef770d164 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = caffe2-cuda-git
pkgdesc = A new lightweight, modular, and scalable deep learning framework (with cuda, git version)
- pkgver = 0.8.2.r13647.ga2ebbccc9f
+ pkgver = 0.8.2.r13650.g93ecf4d72a
pkgrel = 1
url = http://caffe2.ai/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e55de8738dd3..8f3aea996767 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
pkgname=caffe2-cuda-git
-pkgver=0.8.2.r13647.ga2ebbccc9f
+pkgver=0.8.2.r13650.g93ecf4d72a
pkgrel=1
pkgdesc='A new lightweight, modular, and scalable deep learning framework (with cuda, git version)'
arch=('x86_64')
@@ -132,6 +132,7 @@ pkgver() {
build() {
cd pytorch-git
+ export TORCH_CUDA_ARCH_LIST='Auto'
local _pythonver
_pythonver="$(python --version | awk '{ print $2 }' | grep -o '^[0-9]*\.[0-9]*')"
@@ -153,7 +154,6 @@ build() {
-DCMAKE_INSTALL_LIBDIR:PATH='lib' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
\
- -DCUDA_ARCH_NAME:STRING='Auto' \
-DCUDA_HOST_COMPILER:FILEPATH='/usr/bin/gcc-7' \
-DCUDA_NVCC_EXECUTABLE:FILEPATH='/opt/cuda/bin/nvcc' \
-DCUDA_SDK_ROOT_DIR:PATH='/opt/cuda' \