summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-03-05 21:54:37 +0000
committerDaniel Bermond2019-03-05 21:54:37 +0000
commitd3480442d980aac3f90793a3f547ee89e5d4ac48 (patch)
tree1643abc59c64bd70444313549cf05a05eae10868
parent953f303217a717564743e29dd30fe337f7816a45 (diff)
downloadaur-d3480442d980aac3f90793a3f547ee89e5d4ac48.tar.gz
Update git submodules. Fix build issue with cudnn path.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 28 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2927d181d6cc..b7a4f4d9b62b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = caffe2-cuda-git
pkgdesc = A new lightweight, modular, and scalable deep learning framework (with cuda, git version)
- pkgver = 0.8.2.r14826.gf79fb58744
- pkgrel = 2
+ pkgver = 0.8.2.r16592.g079093a662
+ pkgrel = 1
url = https://caffe2.ai/
arch = x86_64
license = BSD
@@ -63,7 +63,7 @@ pkgbase = caffe2-cuda-git
source = git+https://github.com/google/protobuf.git
source = git+https://github.com/Yangqing/ios-cmake.git
source = git+https://github.com/Maratyszcza/NNPACK.git
- source = git+https://github.com/facebookincubator/gloo
+ source = git+https://github.com/facebookincubator/gloo.git
source = git+https://github.com/Maratyszcza/pthreadpool.git
source = git+https://github.com/Maratyszcza/FXdiv.git
source = git+https://github.com/Maratyszcza/FP16.git
@@ -75,14 +75,15 @@ pkgbase = caffe2-cuda-git
source = git+https://github.com/benjaminp/six.git
source = git+https://github.com/ARM-software/ComputeLibrary.git
source = git+https://github.com/onnx/onnx.git
- source = git+https://github.com/onnx/onnx-tensorrt
- source = git+https://github.com/shibatch/sleef
- source = git+https://github.com/intel/ideep
- source = git+https://github.com/NVIDIA/nccl
+ source = git+https://github.com/bddppq/onnx-tensorrt.git
+ source = git+https://github.com/zdevito/sleef.git
+ source = git+https://github.com/intel/ideep.git
+ source = git+https://github.com/NVIDIA/nccl.git
source = git+https://github.com/google/gemmlowp.git
- source = git+https://github.com/pytorch/QNNPACK
+ source = git+https://github.com/pytorch/QNNPACK.git
source = git+https://github.com/intel/ARM_NEON_2_x86_SSE.git
- source = git+https://github.com/pytorch/fbgemm
+ source = git+https://github.com/pytorch/fbgemm.git
+ source = git+https://github.com/houseroad/foxi.git
source = git+https://github.com/asmjit/asmjit.git
sha256sums = SKIP
sha256sums = SKIP
@@ -114,6 +115,7 @@ pkgbase = caffe2-cuda-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = caffe2-cuda-git
diff --git a/PKGBUILD b/PKGBUILD
index 1e195d0ac79d..9297036e2a03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=caffe2-cuda-git
_srcname=pytorch
-pkgver=0.8.2.r14826.gf79fb58744
-pkgrel=2
+pkgver=0.8.2.r16592.g079093a662
+pkgrel=1
pkgdesc='A new lightweight, modular, and scalable deep learning framework (with cuda, git version)'
arch=('x86_64')
url='https://caffe2.ai/'
@@ -44,7 +44,7 @@ source=(
'git+https://github.com/google/protobuf.git'
'git+https://github.com/Yangqing/ios-cmake.git'
'git+https://github.com/Maratyszcza/NNPACK.git'
- 'git+https://github.com/facebookincubator/gloo'
+ 'git+https://github.com/facebookincubator/gloo.git'
'git+https://github.com/Maratyszcza/pthreadpool.git'
'git+https://github.com/Maratyszcza/FXdiv.git'
'git+https://github.com/Maratyszcza/FP16.git'
@@ -56,14 +56,15 @@ source=(
'git+https://github.com/benjaminp/six.git'
'git+https://github.com/ARM-software/ComputeLibrary.git'
'git+https://github.com/onnx/onnx.git'
- 'git+https://github.com/onnx/onnx-tensorrt'
- 'git+https://github.com/shibatch/sleef'
- 'git+https://github.com/intel/ideep'
- 'git+https://github.com/NVIDIA/nccl'
+ 'git+https://github.com/bddppq/onnx-tensorrt.git'
+ 'git+https://github.com/zdevito/sleef.git'
+ 'git+https://github.com/intel/ideep.git'
+ 'git+https://github.com/NVIDIA/nccl.git'
'git+https://github.com/google/gemmlowp.git'
- 'git+https://github.com/pytorch/QNNPACK'
+ 'git+https://github.com/pytorch/QNNPACK.git'
'git+https://github.com/intel/ARM_NEON_2_x86_SSE.git'
- 'git+https://github.com/pytorch/fbgemm'
+ 'git+https://github.com/pytorch/fbgemm.git'
+ 'git+https://github.com/houseroad/foxi.git'
# others:
'git+https://github.com/asmjit/asmjit.git'
)
@@ -96,6 +97,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -104,7 +106,7 @@ prepare() {
local _submodule
local _submodule_list="pybind11 cub googletest benchmark protobuf ios-cmake \
NNPACK gloo zstd ComputeLibrary onnx onnx-tensorrt \
- sleef ideep QNNPACK fbgemm"
+ sleef ideep QNNPACK fbgemm foxi"
git submodule init
@@ -168,8 +170,6 @@ build() {
-DBUILD_PYTHON:BOOL='ON' \
-DBUILD_SHARED_LIBS:BOOL='ON' \
\
- -DBUILD_TEST:BOOL='ON' \
- \
-DCMAKE_CXX_COMPILER='/usr/bin/g++-7' \
-DCMAKE_C_COMPILER='/usr/bin/gcc-7' \
-DCMAKE_INSTALL_LIBDIR:PATH='lib' \
@@ -183,8 +183,6 @@ build() {
-DCUDA_TOOLKIT_INCLUDE:PATH='/opt/cuda/include' \
-DCUDA_TOOLKIT_ROOT_DIR:PATH='/opt/cuda' \
-DCUDA_USE_STATIC_CUDA_RUNTIME:BOOL='OFF' \
- -DCUDNN_INCLUDE_DIR:PATH='/opt/cuda/include' \
- -DCUDNN_LIBRARY:FILEPATH='/opt/cuda/lib64/libcudnn.so' \
-DCUDNN_ROOT_DIR:PATH='/opt/cuda' \
\
-DGLOO_STATIC_OR_SHARED:STRING='STATIC' \
@@ -201,7 +199,7 @@ build() {
-DUSE_CUDA:BOOL='ON' \
-DUSE_CUDNN:BOOL='ON' \
-DUSE_DISTRIBUTED:BOOL='ON' \
- -DUSE_FBGEMM:BOOL='OFF' \
+ -DUSE_FBGEMM:BOOL='ON' \
-DUSE_FFMPEG:BOOL='ON' \
-DUSE_GFLAGS:BOOL='ON' \
-DUSE_GLOG:BOOL='ON' \
@@ -213,10 +211,9 @@ build() {
-DUSE_LMDB:BOOL='ON' \
-DUSE_METAL:BOOL='OFF' \
-DUSE_MKLDNN:BOOL='OFF' \
- -DUSE_MOBILE_OPENGL:BOOL='OFF' \
-DUSE_MPI:BOOL='ON' \
-DUSE_NCCL:BOOL='ON' \
- -DUSE_NNAPI:BOOL='OFF' \
+ -DUSE_NNAPI:BOOL='ON' \
-DUSE_NNPACK:BOOL='ON' \
-DUSE_NUMA:BOOL='ON' \
-DUSE_NUMPY:BOOL='ON' \
@@ -236,6 +233,7 @@ build() {
-DUSE_TENSORRT:BOOL='OFF' \
-DUSE_ZMQ:BOOL='ON' \
-DUSE_ZSTD:BOOL='ON' \
+ -DWITH_OPENMP:BOOL='ON' \
\
-Wno-dev \
..
@@ -246,12 +244,6 @@ build() {
make
}
-check() {
- cd "${_srcname}/build"
-
- make test
-}
-
package() {
cd "${_srcname}/build"
@@ -262,9 +254,9 @@ package() {
local _exclude_dirs
mapfile -t -d '' _exclude_dirs < <(find "${pkgdir}/usr/include" -mindepth 1 -maxdepth 1 -type d ! -name 'caffe*' -print0)
rm "$pkgdir"/usr/bin/{protoc,unzstd,zstd{cat,mt,}}
- rm "$pkgdir"/usr/include/{*.h,*.py}
+ rm "$pkgdir"/usr/include/*.h
rm "$pkgdir"/usr/lib/*.a
- rm "$pkgdir"/usr/lib/lib{zstd,onnxifi}*
+ rm "$pkgdir"/usr/lib/lib{foxi,onnxifi,zstd}*
rm -r "$pkgdir"/usr/lib/cmake/protobuf
rm "$pkgdir"/usr/lib/pkgconfig/{protobuf-lite,protobuf}.pc
rm "$pkgdir"/usr/share/pkgconfig/libzstd.pc