summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-03-28 20:31:44 +0000
committerDaniel Bermond2021-03-28 20:31:44 +0000
commit521390f62a2444b01f56e8761e0ee98ac214b637 (patch)
treedb6394835137887739d047264c4cf42fd8fd53a3
parentd46f4e0a2278c4301f461bdfe50c5f6a0b786e44 (diff)
downloadaur-caffe2-git.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO6
-rw-r--r--010-caffe2-fix-include-system-path.patch2
-rw-r--r--020-caffe2-use-system-libuv.patch2
-rw-r--r--PKGBUILD13
4 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b7653adcc2a..a6541964d239 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = caffe2-git
pkgdesc = A new lightweight, modular, and scalable deep learning framework
- pkgver = 0.8.2.r34171.gdbbe0a2105b
+ pkgver = 0.8.2.r34802.g01b15570145
pkgrel = 1
epoch = 1
url = https://caffe2.ai/
@@ -130,8 +130,8 @@ pkgbase = caffe2-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = c68ddbd539e2a8ef3a1874a65e9c6701fc9d136b592be095b953cdcab38815fd
- sha256sums = cfe57df7a34de8d9fe14b2499d8a211d0670f8a9cb7c999110577fb1626b4b03
+ sha256sums = d926cdacdbddf2334ac8b49602d9e1b12afb01c63a7dd0fb303dbc5d987c0ead
+ sha256sums = 497225e56a88a2c2f65eac4d6240297e42abb298654ad843a70c3c5a10d7170c
sha256sums = 7385ac0742f00245c3bd7560e33648566a25b950964806c55b6c3eaee25981ac
pkgname = caffe2-git
diff --git a/010-caffe2-fix-include-system-path.patch b/010-caffe2-fix-include-system-path.patch
index 5c72921f0dfc..c885e15dd8cd 100644
--- a/010-caffe2-fix-include-system-path.patch
+++ b/010-caffe2-fix-include-system-path.patch
@@ -1,6 +1,6 @@
--- a/torch/utils/cpp_extension.py
+++ b/torch/utils/cpp_extension.py
-@@ -1760,7 +1760,7 @@ def _write_ninja_file_to_build_library(path,
+@@ -1759,7 +1759,7 @@ def _write_ninja_file_to_build_library(path,
common_cflags.append(f'-DPYBIND11_{pname}=\\"{pval}\\"')
common_cflags += [f'-I{include}' for include in user_includes]
diff --git a/020-caffe2-use-system-libuv.patch b/020-caffe2-use-system-libuv.patch
index 9aec7edcdce9..5592e298b964 100644
--- a/020-caffe2-use-system-libuv.patch
+++ b/020-caffe2-use-system-libuv.patch
@@ -1,6 +1,6 @@
--- a/cmake/Dependencies.cmake
+++ b/cmake/Dependencies.cmake
-@@ -1348,7 +1348,7 @@ if(USE_DISTRIBUTED AND USE_TENSORPIPE)
+@@ -1357,7 +1357,7 @@ if(USE_DISTRIBUTED AND USE_TENSORPIPE)
set(TP_USE_CUDA ON CACHE BOOL "" FORCE)
set(TP_ENABLE_CUDA_IPC ON CACHE BOOL "" FORCE)
endif()
diff --git a/PKGBUILD b/PKGBUILD
index dff34f316aab..15e568137843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _cuda_archs='5.2;5.3;6.0;6.1;6.2;7.0;7.0+PTX;7.2;7.2+PTX;7.5;7.5+PTX;8.0;8.0+PTX
pkgbase=caffe2-git
pkgname=('caffe2-git' 'caffe2-cuda-git')
-pkgver=0.8.2.r34171.gdbbe0a2105b
+pkgver=0.8.2.r34802.g01b15570145
pkgrel=1
epoch=1
pkgdesc='A new lightweight, modular, and scalable deep learning framework'
@@ -106,8 +106,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'c68ddbd539e2a8ef3a1874a65e9c6701fc9d136b592be095b953cdcab38815fd'
- 'cfe57df7a34de8d9fe14b2499d8a211d0670f8a9cb7c999110577fb1626b4b03'
+ 'd926cdacdbddf2334ac8b49602d9e1b12afb01c63a7dd0fb303dbc5d987c0ead'
+ '497225e56a88a2c2f65eac4d6240297e42abb298654ad843a70c3c5a10d7170c'
'7385ac0742f00245c3bd7560e33648566a25b950964806c55b6c3eaee25981ac')
prepare() {
@@ -130,7 +130,8 @@ prepare() {
'tbb'
'XNNPACK'
'fmt'
- 'tensorpipe')
+ 'tensorpipe'
+ 'kineto')
git -C pytorch submodule init
@@ -148,6 +149,7 @@ prepare() {
git -C pytorch config --local submodule.third_party/NNPACK_deps/FXdiv.url "${srcdir}/FXdiv"
git -C pytorch config --local submodule.third_party/NNPACK_deps/FP16.url "${srcdir}/FP16"
git -C pytorch config --local submodule.third_party/NNPACK_deps/psimd.url "${srcdir}/psimd"
+ git -C pytorch config --local submodule.third_party/cpuinfo.url "${srcdir}/cpuinfo-pytorch"
git -C pytorch config --local submodule.third_party/python-enum.url "${srcdir}/enum34"
git -C pytorch config --local submodule.third_party/python-peachpy.url "${srcdir}/PeachPy"
git -C pytorch config --local submodule.third_party/python-six.url "${srcdir}/six"
@@ -156,9 +158,6 @@ prepare() {
git -C pytorch config --local submodule.third_party/gemmlowp/gemmlowp.url "${srcdir}/gemmlowp"
git -C pytorch config --local submodule.android/libs/fbjni.url "${srcdir}/fbjni"
- # special case (upstream uses third-party instead of third_party)
- git -C pytorch config --local submodule.third-party/cpuinfo.url "${srcdir}/cpuinfo-pytorch"
-
git -C pytorch submodule update
# fbgemm submodules