summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-23 17:23:58 -0300
committerDaniel Bermond2017-08-23 17:23:58 -0300
commit9f98535bd8b1687bdd4637a94ae9bf69a9aa47d9 (patch)
tree84d2a33c059897cd57b1ae5652645ede7c0d5bf2
parentca34ef263cb4a3dd1976c5d942df797be0cc8a0e (diff)
downloadaur-9f98535bd8b1687bdd4637a94ae9bf69a9aa47d9.tar.gz
Enabled ffmpeg and observers. Removed the deprecated cnmem option.
Also on this commit: - explicitly added the options 'USE_METAL' and 'USE_MOBILE_OPENGL', setting both of them to 'OFF'.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceef7f2a0d1..4a6b321b905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Aug 23 18:59:01 UTC 2017
+# Wed Aug 23 20:23:55 UTC 2017
pkgbase = caffe2-git
pkgdesc = A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)
- pkgver = 0.8.1.r19.gf0ea8046
- pkgrel = 2
+ pkgver = 0.8.1.r120.g898ba8bf
+ pkgrel = 1
url = http://caffe2.ai/
arch = x86_64
license = BSD
@@ -29,6 +29,7 @@ pkgbase = caffe2-git
depends = snappy
depends = zeromq
depends = hiredis
+ depends = ffmpeg
depends = python2-flask
depends = python2-future
depends = graphviz
diff --git a/PKGBUILD b/PKGBUILD
index b2b56bc2131..139c66d3bea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
pkgname=caffe2-git
-pkgver=0.8.1.r19.gf0ea8046
-pkgrel=2
+pkgver=0.8.1.r120.g898ba8bf
+pkgrel=1
pkgdesc='A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -14,7 +14,7 @@ depends=(
'cudnn'
# not required but enabled in build:
'gflags' 'gtest' 'openmp' 'leveldb' 'lmdb' 'openmpi' 'snappy' 'zeromq'
- 'hiredis'
+ 'hiredis' 'ffmpeg'
# python2:
'python2-flask' 'python2-future' 'graphviz' 'python2-hypothesis'
'python2-jupyter_core' 'python2-matplotlib' 'python2-pydot' 'python2-yaml'
@@ -157,7 +157,6 @@ build() {
-DPYTHON_INCLUDE_DIR:PATH='/usr/include/python2.7' \
-DPYTHON_LIBRARY:FILEPATH='/usr/lib/libpython2.7.so' \
\
- -DUSE_CNMEM:BOOL='OFF' \
-DUSE_CUDA:BOOL='ON' \
-DUSE_GFLAGS:BOOL='ON' \
-DUSE_GLOG:BOOL='ON' \
@@ -165,12 +164,15 @@ build() {
-DUSE_LEVELDB:BOOL='ON' \
-DUSE_LITE_PROTO:BOOL='OFF' \
-DUSE_LMDB:BOOL='ON' \
+ -DUSE_METAL:BOOL='OFF' \
+ -DUSE_MOBILE_OPENGL:BOOL='OFF' \
-DUSE_MPI:BOOL='ON' \
-DUSE_NCCL:BOOL='ON' \
-DUSE_NERVANA_GPU:BOOL='ON' \
-DUSE_NNPACK:BOOL='ON' \
+ -DUSE_OBSERVERS:BOOL='ON' \
-DUSE_OPENCV:BOOL='OFF' \
- -DUSE_FFMPEG:BOOL='OFF' \
+ -DUSE_FFMPEG:BOOL='ON' \
-DUSE_OPENMP:BOOL='ON' \
-DUSE_REDIS:BOOL='ON' \
-DUSE_ROCKSDB:BOOL='OFF' \