summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-09-03 13:13:09 -0300
committerDaniel Bermond2017-09-03 13:13:09 -0300
commitae23a1344c49640a0be09b752a74abe38884c204 (patch)
tree9f3db99d2ff1bfa6a816237475093148803abd49
parent8d43fe79b6978eb7439c3faec62689ea80d40460 (diff)
downloadaur-ae23a1344c49640a0be09b752a74abe38884c204.tar.gz
Removed NCCL support (it can be enabled by modifying the proper lines)
The newly released NCCL version 2 requires registration at the NVIDIA developer webiste and a manual download. As this breaks automated builds by AUR helpers, NCCL was disabled by default in this package. It can still be enabled by modifying the proper lines in the PKGBUILD file (instructions are at the top of the PKGBUILD file).
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa7292d591d1..37d2882cac82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 3 16:01:48 UTC 2017
+# Sun Sep 3 16:13:03 UTC 2017
pkgbase = caffe2-git
pkgdesc = A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)
- pkgver = 0.8.1.r120.g898ba8bf
- pkgrel = 2
+ pkgver = 0.8.1.r218.gf2a14f34
+ pkgrel = 1
url = http://caffe2.ai/
arch = x86_64
license = BSD
@@ -45,7 +45,6 @@ pkgbase = caffe2-git
depends = python2-tornado
depends = python2-gflags
depends = python2-pyzmq
- depends = nccl
depends = python2-nvd3
depends = python2-scikit-image
depends = python2-glog
diff --git a/PKGBUILD b/PKGBUILD
index 223a2093776d..b52de109a61b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,17 @@
# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# NOTE:
+# In order to build with NCCL support, follow these steps:
+# - uncomment the nccl line in 'depends'
+# - in 'build()', change '-DUSE_NCCL:BOOL=OFF' from 'OFF' to 'ON'
+# - add these options to cmake command line:
+# -DNCCL_INCLUDE_DIR:PATH='/opt/cuda/include'
+# -DNCCL_LIBRARY:FILEPATH='/opt/cuda/lib64/libnccl.so'
+# -DNCCL_ROOT_DIR:PATH='/opt/cuda'
+
pkgname=caffe2-git
-pkgver=0.8.1.r120.g898ba8bf
-pkgrel=2
+pkgver=0.8.1.r218.gf2a14f34
+pkgrel=1
pkgdesc='A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -21,8 +30,8 @@ depends=(
'python2-requests' 'python2-scipy' 'python2-setuptools' 'python2-six'
'python2-tornado' 'python2-gflags' 'python2-pyzmq'
# AUR:
- # not required but enabled in build:
- 'nccl'
+ # not required:
+ # 'nccl'
# python2:
'python2-nvd3' 'python2-scikit-image' 'python2-glog' 'python2-leveldb'
'python2-lmdb'
@@ -144,9 +153,6 @@ build() {
-DCUDNN_ROOT_DIR:PATH='/opt/cuda' \
\
-DGLOO_STATIC_OR_SHARED:STRING='STATIC' \
- -DNCCL_INCLUDE_DIR:PATH='/opt/cuda/include' \
- -DNCCL_LIBRARY:FILEPATH='/opt/cuda/lib64/libnccl.so' \
- -DNCCL_ROOT_DIR:PATH='/opt/cuda' \
\
-DOpenCV_DIR:PATH='/usr/share/OpenCV' \
\
@@ -164,7 +170,7 @@ build() {
-DUSE_METAL:BOOL='OFF' \
-DUSE_MOBILE_OPENGL:BOOL='OFF' \
-DUSE_MPI:BOOL='ON' \
- -DUSE_NCCL:BOOL='ON' \
+ -DUSE_NCCL:BOOL='OFF' \
-DUSE_NERVANA_GPU:BOOL='ON' \
-DUSE_NNPACK:BOOL='ON' \
-DUSE_OBSERVERS:BOOL='ON' \