summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-23 15:59:09 -0300
committerDaniel Bermond2017-08-23 15:59:09 -0300
commitca34ef263cb4a3dd1976c5d942df797be0cc8a0e (patch)
treee0c8aab53ce79bb02092e0ae224890568685a172
parentfa6cf7cca8aa3d2eeb34634778347e349296d56b (diff)
downloadaur-ca34ef263cb4a3dd1976c5d942df797be0cc8a0e.tar.gz
Added missing python dependencies (six, future and nvd3)
Adding python-future fixes an error when importing the caffe2 python modules. Thanks to AUR user wangqr for pointing this.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aab5e538836..ceef7f2a0d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Aug 10 01:28:21 UTC 2017
+# Wed Aug 23 18:59:01 UTC 2017
pkgbase = caffe2-git
pkgdesc = A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)
pkgver = 0.8.1.r19.gf0ea8046
- pkgrel = 1
+ pkgrel = 2
url = http://caffe2.ai/
arch = x86_64
license = BSD
@@ -29,24 +29,27 @@ pkgbase = caffe2-git
depends = snappy
depends = zeromq
depends = hiredis
- depends = python2-pydot
depends = python2-flask
+ depends = python2-future
depends = graphviz
depends = python2-hypothesis
depends = python2-jupyter_core
depends = python2-matplotlib
+ depends = python2-pydot
depends = python2-yaml
depends = python2-requests
depends = python2-scipy
depends = python2-setuptools
+ depends = python2-six
depends = python2-tornado
- depends = python2-pyzmq
depends = python2-gflags
+ depends = python2-pyzmq
depends = nccl
+ depends = python2-nvd3
depends = python2-scikit-image
+ depends = python2-glog
depends = python2-leveldb
depends = python2-lmdb
- depends = python2-glog
provides = caffe2
conflicts = caffe
conflicts = caffe-cpu
diff --git a/PKGBUILD b/PKGBUILD
index f3191ce087f..b2b56bc2131 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=caffe2-git
pkgver=0.8.1.r19.gf0ea8046
-pkgrel=1
+pkgrel=2
pkgdesc='A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -16,17 +16,16 @@ depends=(
'gflags' 'gtest' 'openmp' 'leveldb' 'lmdb' 'openmpi' 'snappy' 'zeromq'
'hiredis'
# python2:
- 'python2-pydot' 'python2-flask' 'graphviz' 'python2-hypothesis'
- 'python2-jupyter_core' 'python2-matplotlib' 'python2-yaml' 'python2-requests'
- 'python2-scipy' 'python2-setuptools' 'python2-tornado' 'python2-pyzmq'
- 'python2-gflags'
+ 'python2-flask' 'python2-future' 'graphviz' 'python2-hypothesis'
+ 'python2-jupyter_core' 'python2-matplotlib' 'python2-pydot' 'python2-yaml'
+ 'python2-requests' 'python2-scipy' 'python2-setuptools' 'python2-six'
+ 'python2-tornado' 'python2-gflags' 'python2-pyzmq'
# AUR:
# not required but enabled in build:
'nccl'
# python2:
- 'python2-scikit-image' 'python2-leveldb' 'python2-lmdb' 'python2-glog'
- # missing:
- # 'python2-nvd3'
+ 'python2-nvd3' 'python2-scikit-image' 'python2-glog' 'python2-leveldb'
+ 'python2-lmdb'
)
makedepends=(
# official repositories: