summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Smith2017-09-29 10:33:02 -0400
committerStephen Smith2017-09-29 10:33:02 -0400
commite1bd4c7e4e313b8c88f9bbe2415c99ccedcea044 (patch)
treeb68b52b8ed8ae42ba14a47dbb731078c82912043
downloadaur-e1bd4c7e4e313b8c88f9bbe2415c99ccedcea044.tar.gz
Initial commit.
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD27
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..130d5ac8fd91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Fri Sep 29 14:31:22 UTC 2017
+pkgbase = caffeine
+ pkgdesc = A easy way to control powersaving on your desktop.
+ pkgver = 2.6.2
+ pkgrel = 1
+ url = https://launchpad.net/caffeine
+ arch = any
+ license = GPL3
+ depends = python-gobject
+ depends = python-ewmh
+ provides = caffeine-bzr
+ provides = caffeine-ng
+ provides = caffeine-oneclick
+ provides = caffeine-systray
+ conflicts = caffeine-bzr
+ conflicts = caffeine-ng
+ conflicts = caffeine-oneclick
+ conflicts = caffeine-systray
+ replaces = caffeine-oneclick
+ replaces = caffeine-systray
+ options = !emptydirs
+ options = !libtool
+ source = https://launchpad.net/caffeine/2.6/2.6/+download/caffeine_2.6.2.tar.gz
+ md5sums = 91d254a124d83f266470c2118592425d
+
+pkgname = caffeine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9adf4eb0600c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Stephen Smith <stephen304@gmail.com>
+
+pkgname=caffeine
+pkgver=2.6.2
+pkgrel=1
+pkgdesc="A easy way to control powersaving on your desktop."
+arch=(any)
+url="https://launchpad.net/caffeine"
+license=(GPL3)
+depends=(python-gobject python-ewmh)
+conflicts=(caffeine-bzr caffeine-ng caffeine-oneclick caffeine-systray)
+provides=(caffeine-bzr caffeine-ng caffeine-oneclick caffeine-systray)
+replaces=(caffeine-oneclick caffeine-systray)
+options=(!emptydirs !libtool)
+source=("https://launchpad.net/caffeine/2.6/2.6/+download/caffeine_2.6.2.tar.gz")
+
+md5sums=('91d254a124d83f266470c2118592425d')
+
+build() {
+ cd "$srcdir"/"$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/"$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}