summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-09 01:43:32 -0300
committerHugo Osvaldo Barrera2015-06-09 01:43:32 -0300
commitd42e7fb5fb7b00137043f3184b3a4862753e12d7 (patch)
treefce9b7a69e68f13fa188e34f4c0b28f955aafd98
downloadaur-d42e7fb5fb7b00137043f3184b3a4862753e12d7.tar.gz
Initial commit.
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD29
-rw-r--r--caffeine-ng.install13
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38290fa80916
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = caffeine-ng
+ pkgdesc = Status bar application able to temporarily inhibit the screensaver and sleep mode.
+ pkgver = 3.1
+ pkgrel = 1
+ url = https://github.com/hobarrera/caffeine-ng
+ install = caffeine-ng.install
+ arch = any
+ license = GPL3
+ depends = python-gobject
+ depends = python-xdg
+ depends = python-dbus
+ depends = python-docopt
+ depends = python-ewmh
+ depends = gtk3
+ depends = libnotify
+ depends = python-setproctitle
+ optdepends = libindicator-gtk3: AppIndictor support.
+ provides = caffeine
+ provides = caffeine-bzr
+ provides = caffeine-oneclick
+ provides = caffeine-systray
+ conflicts = caffeine
+ conflicts = caffeine-bzr
+ conflicts = caffeine-oneclick
+ conflicts = caffeine-systray
+ replaces = caffeine-oneclick
+ replaces = caffeine-systray
+ options = !emptydirs
+ options = !libtool
+ source = 3.1.tar.gz::https://git.barrera.io/hobarrera/caffeine-ng/repository/archive.tar.gz?ref=v3.1
+ sha256sums = 08f1034895013d99e31ede006543eabeace368378e36a9be4b27b51a3fd80fc0
+
+pkgname = caffeine-ng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ebd9b9451d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=caffeine-ng
+pkgver=3.1
+pkgrel=1
+pkgdesc="Status bar application able to temporarily inhibit the screensaver and sleep mode."
+arch=(any)
+url=https://github.com/hobarrera/caffeine-ng
+license=(GPL3)
+depends=(python-gobject python-xdg python-dbus python-docopt python-ewmh gtk3
+ libnotify python-setproctitle)
+optdepends=("libindicator-gtk3: AppIndictor support.")
+conflicts=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
+provides=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
+replaces=(caffeine-oneclick caffeine-systray)
+options=(!emptydirs !libtool)
+install=$pkgname.install
+source=("$pkgver.tar.gz::https://git.barrera.io/hobarrera/$pkgname/repository/archive.tar.gz?ref=v$pkgver")
+sha256sums=('08f1034895013d99e31ede006543eabeace368378e36a9be4b27b51a3fd80fc0')
+
+build() {
+ cd $pkgname.git
+ python setup.py build
+}
+
+package() {
+ cd $pkgname.git
+ python setup.py install --root="$pkgdir"
+}
diff --git a/caffeine-ng.install b/caffeine-ng.install
new file mode 100644
index 000000000000..cfa29a3e485f
--- /dev/null
+++ b/caffeine-ng.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -qtf usr/share/icons/hicolor
+ update-desktop-database -q
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}