summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2022-04-18 19:11:15 +0200
committerHugo Osvaldo Barrera2022-04-18 19:11:15 +0200
commite1b545da678f5dac3ff4cdb8089b690ed67551fa (patch)
tree732600f521d0ce3e44a1662c33baa36f13507a71
parent3089f9d84f7fd4c3d44558712ca9c10bf0b9fe04 (diff)
downloadaur-e1b545da678f5dac3ff4cdb8089b690ed67551fa.tar.gz
Adopt PEP 517 tooling
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1662d135ac8..ac392c0438dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = caffeine-ng
pkgdesc = Status bar application able to temporarily inhibit the screensaver and sleep mode.
pkgver = 3.5.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/caffeine-ng/caffeine-ng
arch = any
license = GPL3
makedepends = git
makedepends = python-setuptools-scm
+ makedepends = python-build
+ makedepends = python-installer
depends = python-gobject
depends = python-xdg
depends = python-dbus
diff --git a/PKGBUILD b/PKGBUILD
index b3f35febf2df..745a4d9b17e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=caffeine-ng
pkgver=3.5.1
-pkgrel=2
+pkgrel=3
pkgdesc="Status bar application able to temporarily inhibit the screensaver and sleep mode."
arch=(any)
url="https://github.com/caffeine-ng/caffeine-ng"
@@ -11,7 +11,12 @@ depends=(python-gobject python-xdg python-dbus python-docopt python-ewmh gtk3
libnotify python-setproctitle python-setuptools python-wheel
python-pulsectl)
optdepends=("libappindicator-gtk3: AppIndicator support (eg: Plasma, Unity).")
-makedepends=(git python-setuptools-scm)
+makedepends=(
+ git
+ python-setuptools-scm
+ python-build
+ python-installer
+)
conflicts=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
provides=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
replaces=(caffeine-oneclick caffeine-systray)
@@ -21,10 +26,10 @@ md5sums=('c56988059680bcd25525480f8688f81e')
build() {
cd "$srcdir"/caffeine-ng-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir"/caffeine-ng-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}