diff options
author | Aseem Athale | 2024-05-22 21:17:20 +0530 |
---|---|---|
committer | Aseem Athale | 2024-05-22 21:56:50 +0530 |
commit | fccbd82cf305003ecddead282c499fd846e82d17 (patch) | |
tree | 0329a97c4abaa9318cdad1eb03bf19fab590d21e | |
parent | d166127b640a885ee9e9fe748f45391e82c441d3 (diff) | |
download | aur-fccbd82cf305003ecddead282c499fd846e82d17.tar.gz |
caffeine-ng-git: Refactor PKGBUILD
Sync up the dependencies with upstream, remove obsolete conflicts and
strip 'v' from version number as per Arch packaging guidelines.
Signed-off-by: Aseem Athale <athaleaseem@gmail.com>
-rw-r--r-- | .SRCINFO | 7 | ||||
-rw-r--r-- | PKGBUILD | 33 |
2 files changed, 13 insertions, 27 deletions
@@ -1,14 +1,15 @@ pkgbase = caffeine-ng-git pkgdesc = Status bar application able to temporarily inhibit the screensaver and sleep mode. - pkgver = v4.0.2.r28.g5c7e1b5 + pkgver = 4.2.0.r34.g1c638ba pkgrel = 1 url = https://codeberg.org/WhyNotHugo/caffeine-ng arch = any license = GPL3 makedepends = git makedepends = meson + makedepends = scdoc + depends = python depends = python-gobject - depends = python-xdg depends = dbus-python depends = python-click depends = python-ewmh @@ -18,7 +19,7 @@ pkgbase = caffeine-ng-git depends = python-pulsectl depends = libindicator-gtk3 depends = libappindicator-gtk3 - depends = scdoc + optdepends = xfconf provides = caffeine provides = caffeine-bzr provides = caffeine-oneclick @@ -1,40 +1,25 @@ -# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io> +# Maintainer: Aseem Athale <athaleaseem@gmail.com> +# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io> pkgname=caffeine-ng-git _pkgname=caffeine-ng -pkgver=v4.0.2.r28.g5c7e1b5 +pkgver=4.2.0.r34.g1c638ba pkgrel=1 pkgdesc="Status bar application able to temporarily inhibit the screensaver and sleep mode." arch=(any) url="https://codeberg.org/WhyNotHugo/caffeine-ng" license=(GPL3) -depends=( - python-gobject - python-xdg - dbus-python - python-click - python-ewmh - gtk3 - libnotify - python-setproctitle - python-pulsectl - libindicator-gtk3 - libappindicator-gtk3 - scdoc -) -makedepends=( - git - meson -) -conflicts=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray caffeine-ng) -provides=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray caffeine-ng) -replaces=(caffeine-oneclick caffeine-systray) +depends=('python' 'python-click' 'dbus-python' 'python-ewmh' 'python-gobject' 'python-pulsectl' 'python-setproctitle' 'gtk3' 'libnotify' 'libayatana-appindicator' 'libayatana-indicator' 'xdg-utils') +makedepends=('git' 'meson' 'scdoc') +optdepends=('xfconf' 'libindicator-gtk3' 'libappindicator-gtk3') +conflicts=('caffeine' 'caffeine-bzr' 'caffeine-ng' 'caffeine-ng-regex') +provides=('caffeine' 'caffeine-bzr' 'caffeine-ng' 'caffeine-ng-regex') source=("git+https://codeberg.org/WhyNotHugo/$_pkgname.git") sha256sums=('SKIP') pkgver() { cd "$srcdir/$_pkgname" - git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' + git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' } build() { |