summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-06-21 11:28:35 +0300
committerDimitris Kiziridis2020-06-21 11:28:35 +0300
commit0cb3b47577260a8dfa5efadad11e81973275e560 (patch)
tree40d6a63c322b5855c822cc524571535db7774a52
downloadaur-0cb3b47577260a8dfa5efadad11e81973275e560.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE39
-rw-r--r--PKGBUILD35
-rw-r--r--caffviewer.pngbin0 -> 30547 bytes
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..327525bda5de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = caffviewer
+ pkgdesc = The de·caff Viewer version 3.x is a pure Java program for viewing AutoCAD® DWG, DXF and SHX files
+ pkgver = 3.13.08
+ pkgrel = 1
+ url = https://caff.de/projects/caffviewer/
+ arch = x86_64
+ license = Apache
+ license = custom:caffviewer
+ makedepends = gendesk
+ depends = java-runtime>=8
+ depends = bash
+ noextract = caffviewer-3.13.08.jar
+ source = caffviewer-3.13.08.jar::https://caff.de/projects/caffviewer/caffviewer.jar
+ source = LICENSE
+ source = caffviewer.png
+ sha256sums = 394ae976c6909ffa56da523c1ec8e30c090e72e797425a696af570d23688de64
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = caffviewer
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a3060d4ff791
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,39 @@
+The viewer is not Open Source, but the usage of the viewer is free of any charge. You may download it and use it at your own risk. Although doing my best to make it a useful tool there is no guarantee for this.
+
+3rd Party Code
+
+The viewer uses a few Open Source libraries. They run under the following licenses.
+
+Public Domain Code
+
+For displaying files dragged on the viewer FileDrop by Robert Harder is used. It’s in the public domain. Thank you, Robert!
+Others
+
+For displaying balloon tool tips the BalloonTip library by Bernhard Pauler and Tim Molderez is used. It is provided under the following license:
+
+Copyright © 2011 Bernhard Pauler, Tim Molderez
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the Balloon tip Developer Team nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE BALLOON TIP DEVELOPER TEAM BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+Thank you, Bernhard and Tim! \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49f657ef741b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=caffviewer
+pkgver=3.13.08
+pkgrel=1
+pkgdesc="The de·caff Viewer version 3.x is a pure Java program for viewing AutoCAD® DWG, DXF and SHX files"
+arch=('x86_64')
+url='https://caff.de/projects/caffviewer/'
+license=('Apache' "custom:${pkgname}")
+depends=('java-runtime>=8' 'bash')
+makedepends=('gendesk')
+noextract=("${pkgname}-${pkgver}.jar")
+source=("${pkgname}-${pkgver}.jar::https://caff.de/projects/caffviewer/caffviewer.jar"
+ 'LICENSE'
+ 'caffviewer.png')
+sha256sums=('394ae976c6909ffa56da523c1ec8e30c090e72e797425a696af570d23688de64'
+ 'SKIP'
+ 'SKIP')
+
+package() {
+ install -Dm644 ${pkgname}-${pkgver}.jar -t "${pkgdir}/usr/share/java/${pkgname}"
+ echo "#!/usr/bin/env bash
+ exec /usr/bin/java -jar '/usr/share/java/${pkgname}/${pkgname}-${pkgver}.jar' "\$\@"" > caffviewer.sh
+ install -Dm755 caffviewer.sh "${pkgdir}/usr/bin/caffviewer"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ gendesk -f -n --pkgname "${pkgname}" \
+ --pkgdesc "$pkgdesc" \
+ --name "de·caff Viewer" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname}" \
+ --categories 'Graphics;Application;' \
+ --icon "${pkgname}"
+ install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 caffviewer.png -t "${pkgdir}/usr/share/pixmaps"
+} \ No newline at end of file
diff --git a/caffviewer.png b/caffviewer.png
new file mode 100644
index 000000000000..97ba036127a0
--- /dev/null
+++ b/caffviewer.png
Binary files differ