summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2024-01-16 17:48:21 -0600
committerkyechou2024-01-16 17:48:25 -0600
commit827728a9bcddeda859aedd7cb73d5a1e090bb5d0 (patch)
treefb9382a2a0f943037a68ce242f26f369b304c3a1
parent2830afda12fbd437704eec91f4cba9be3aa9ad70 (diff)
downloadaur-827728a9bcddeda859aedd7cb73d5a1e090bb5d0.tar.gz
Depend on wlroots0.16 for now until cage-kiosk/cage#281 is merged
See https://github.com/cage-kiosk/cage/pull/281.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bffb4c56904..71fda5fa8bfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cage-git
pkgdesc = Kiosk compositor for Wayland
- pkgver = 0.1.4.r54.gbd5b20e
+ pkgver = 0.1.5.r13.g34eb3ec
pkgrel = 1
url = https://www.hjdskes.nl/projects/cage/
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = cage-git
makedepends = xorg-server-xwayland
depends = glibc
depends = wayland
- depends = wlroots
+ depends = wlroots0.16
depends = libxkbcommon
depends = pixman
optdepends = polkit: System privilege control. Required if not using seatd service
diff --git a/PKGBUILD b/PKGBUILD
index 60314849a56b..3d7dbf87eb6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Kuan-Yen Chou <kychou2@illinois.edu>
+# Maintainer: Kuan-Yen Chou <kuanyenchou (at) gmail (dot) com>
# Contributor: gilbus <aur(AT)tinkershell.eu>
pkgname=cage-git
-pkgver=0.1.4.r54.gbd5b20e
+pkgver=0.1.5.r13.g34eb3ec
pkgrel=1
pkgdesc="Kiosk compositor for Wayland"
-depends=(glibc wayland wlroots libxkbcommon pixman)
+depends=(glibc wayland wlroots0.16 libxkbcommon pixman)
makedepends=(git meson scdoc wayland-protocols xorg-server-xwayland)
optdepends=(
'polkit: System privilege control. Required if not using seatd service'
@@ -30,6 +30,7 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
+ export PKG_CONFIG_PATH='/usr/lib/wlroots0.16/pkgconfig'
meson setup --buildtype=release -Dxwayland=true --prefix /usr "$srcdir/build"
ninja -C "$srcdir/build"
}