summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorproject-repo2023-01-08 22:31:57 +0100
committerproject-repo2023-01-08 22:31:57 +0100
commit53dece74c86c49b2178dc0a9872793115676aa56 (patch)
tree2437cdf8f899c98f5c7710d32f774bb7f779a857
parent265ffda7677756ed2a40f111154f495740aa50a7 (diff)
downloadaur-53dece74c86c49b2178dc0a9872793115676aa56.tar.gz
Add cagebreak PKGBUILD for release 2.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca4396072d3e..72cfbf556fce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cagebreak
pkgdesc = Tiling wayland compositor based on cage inspired by ratpoison
- pkgver = 1.9.1
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/project-repo/cagebreak
arch = x86_64
@@ -11,14 +11,14 @@ pkgbase = cagebreak
makedepends = wayland-protocols
depends = wayland
depends = libxkbcommon
- depends = wlroots<0.16.0
+ depends = wlroots<0.17.0
depends = pango
optdepends = wl-clipboard: clipboard support
optdepends = xorg-xwayland: x application support
conflicts = cagebreak-bin
options = !buildflags
options = !strip
- source = cagebreak-1.9.1.tar.gz::https://github.com/project-repo/cagebreak/releases/download/1.9.1/release_1.9.1.tar.gz
- sha512sums = 563e985791b4d206f5cf0dc98d8060bd54fd076801a8b56a8f81447ab11f219f352c73ccd4d0113aae7a5dd3d9ff8aee6a166e31b4c2d6705c08dddf479f997a
+ source = cagebreak-2.0.0.tar.gz::https://github.com/project-repo/cagebreak/releases/download/2.0.0/release_2.0.0.tar.gz
+ sha512sums = 9f2ed0721080a1d271db3edf864acad85219be2402fb09f5605f12d4410dd30cdb17f768c6e6fcf77d4fc32f7bb6ed1175ab1b671d8afc8dbface74598696ae8
pkgname = cagebreak
diff --git a/PKGBUILD b/PKGBUILD
index 86a87f9f6a7b..0f0b3a565274 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: project-repo <archlinux-aur@project-repo.co>
pkgname=cagebreak
-pkgver=1.9.1
+pkgver=2.0.0
pkgrel=1
pkgdesc='Tiling wayland compositor based on cage inspired by ratpoison'
arch=('x86_64')
url='https://github.com/project-repo/cagebreak'
license=('MIT')
-depends=('wayland' 'libxkbcommon' 'wlroots<0.16.0' 'pango')
+depends=('wayland' 'libxkbcommon' 'wlroots<0.17.0' 'pango')
makedepends=('meson' 'ninja' 'scdoc' 'wayland-protocols')
optdepends=('wl-clipboard: clipboard support'
'xorg-xwayland: x application support')
options=('!buildflags' '!strip')
conflicts=('cagebreak-bin')
source=("$pkgname-$pkgver.tar.gz::https://github.com/project-repo/cagebreak/releases/download/$pkgver/release_$pkgver.tar.gz")
-sha512sums=('563e985791b4d206f5cf0dc98d8060bd54fd076801a8b56a8f81447ab11f219f352c73ccd4d0113aae7a5dd3d9ff8aee6a166e31b4c2d6705c08dddf479f997a')
+sha512sums=('9f2ed0721080a1d271db3edf864acad85219be2402fb09f5605f12d4410dd30cdb17f768c6e6fcf77d4fc32f7bb6ed1175ab1b671d8afc8dbface74598696ae8')
build() {
cd "$pkgname"
- meson build --buildtype=release -Dman-pages=true -Dxwayland=true
+ meson setup build --buildtype=debug -Dman-pages=true -Dxwayland=true
ninja -C build
}
package() {