summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorproject-repo2023-12-04 12:50:54 +0100
committerproject-repo2023-12-04 12:50:54 +0100
commitc3382b6343b486d9247ba3094041085ccf6069c0 (patch)
tree84828cea8cf73b3e4a86e9fd92da3b0df13908f0
parent6dfe5e2fdadfd3f6c02a66e7ce904dd572c90d86 (diff)
downloadaur-c3382b6343b486d9247ba3094041085ccf6069c0.tar.gz
Add cagebreak PKGBUILD for release 2.2.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e02ff7a0c49..11e26ec1cbdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cagebreak
pkgdesc = Tiling wayland compositor based on cage inspired by ratpoison
- pkgver = 2.2.1
+ pkgver = 2.2.2
pkgrel = 1
url = https://github.com/project-repo/cagebreak
arch = x86_64
@@ -11,14 +11,14 @@ pkgbase = cagebreak
makedepends = wayland-protocols
depends = wayland
depends = libxkbcommon
- depends = wlroots<0.17.0
+ depends = wlroots<0.18.0
depends = pango
optdepends = wl-clipboard: clipboard support
optdepends = xorg-xwayland: x application support
conflicts = cagebreak-bin
options = !buildflags
options = !strip
- source = cagebreak-2.2.1.tar.gz::https://github.com/project-repo/cagebreak/releases/download/2.2.1/release_2.2.1.tar.gz
- sha512sums = 82076b07af4a8f56638bdc872ad7997e308183f3ac1aa3673ee5df7820a36671e3c9d7ee8257cf71cfb4afc011b2701e7d7cb9683c439d023ff1575fb3f1fccf
+ source = cagebreak-2.2.2.tar.gz::https://github.com/project-repo/cagebreak/releases/download/2.2.2/release_2.2.2.tar.gz
+ sha512sums = 52ff49bfa5f7fffc77ff9efbf544f2a1c97c88d3fc8b0bbe0ffe7cd67b6a3ea3ba6f05951654920a4f41aae9da7a21999ec189b42b69d08b5b6f0595163f124a
pkgname = cagebreak
diff --git a/PKGBUILD b/PKGBUILD
index 200d753b0a91..aa3b9204b3fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: project-repo <archlinux-aur@project-repo.co>
pkgname=cagebreak
-pkgver=2.2.1
+pkgver=2.2.2
pkgrel=1
pkgdesc='Tiling wayland compositor based on cage inspired by ratpoison'
arch=('x86_64')
url='https://github.com/project-repo/cagebreak'
license=('MIT')
-depends=('wayland' 'libxkbcommon' 'wlroots<0.17.0' 'pango')
+depends=('wayland' 'libxkbcommon' 'wlroots<0.18.0' 'pango')
makedepends=('meson' 'ninja' 'scdoc' 'wayland-protocols')
optdepends=('wl-clipboard: clipboard support'
'xorg-xwayland: x application support')
options=('!buildflags' '!strip')
conflicts=('cagebreak-bin')
source=("$pkgname-$pkgver.tar.gz::https://github.com/project-repo/cagebreak/releases/download/$pkgver/release_$pkgver.tar.gz")
-sha512sums=('82076b07af4a8f56638bdc872ad7997e308183f3ac1aa3673ee5df7820a36671e3c9d7ee8257cf71cfb4afc011b2701e7d7cb9683c439d023ff1575fb3f1fccf')
+sha512sums=('52ff49bfa5f7fffc77ff9efbf544f2a1c97c88d3fc8b0bbe0ffe7cd67b6a3ea3ba6f05951654920a4f41aae9da7a21999ec189b42b69d08b5b6f0595163f124a')
build() {
meson setup --prefix=/usr --buildtype=release -Dman-pages=true -Dxwayland=true $pkgname build
meson compile -C build