summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2018-02-06 22:17:28 +0100
committerSimon Legner2018-02-06 22:21:05 +0100
commit59e4af0143804d0a66d7bff7c88f174977a51002 (patch)
tree05ef36fafc94613029e72f2d50c424283d11e33e
downloadaur-59e4af0143804d0a66d7bff7c88f174977a51002.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8046cc8b487f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Feb 6 21:20:50 UTC 2018
+pkgbase = caire
+ pkgdesc = Content aware image resize library based on Seam Carving
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/esimov/caire
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ source = https://github.com/esimov/caire/archive/v1.0.1.tar.gz
+ sha256sums = a37f8d46359b75dbe474635c4cd7354538e1be4744c292c756000fb669a3c5de
+
+pkgname = caire
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..308c809d4a90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=caire
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Content aware image resize library based on Seam Carving"
+arch=('x86_64' 'i686')
+url="https://github.com/esimov/caire"
+license=('MIT')
+source=("https://github.com/esimov/$pkgname/archive/v$pkgver.tar.gz")
+makedepends=('go')
+
+_importpath="github.com/esimov/$pkgname"
+
+prepare() {
+ export GOPATH="$srcdir/_go"
+ mkdir -p $(dirname "$GOPATH/src/$_importpath")
+ ln -sf "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$_importpath"
+ cd "$GOPATH/src/$_importpath"
+ go get -t ./...
+}
+
+build() {
+ cd "$GOPATH/src/$_importpath/cmd/$pkgname"
+ go build
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/" "$pkgdir/usr/share/licenses/$pkgname/"
+ install -m644 "$GOPATH/src/$_importpath/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -m755 "$GOPATH/src/$_importpath/cmd/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+sha256sums=('a37f8d46359b75dbe474635c4cd7354538e1be4744c292c756000fb669a3c5de')